クライアントが自サーバーにはいってもすぐに強制切断される現象が続いています。

フォーラムルール
質問関連フォーラムで質問する時は、必ず次のトピックを一読/厳守お願い致します。
viewtopic.php?f=5&t=999

返信する

:
不正プログラムによるアクセスを防ぐため、reCaptcha 認証コードの入力を強制しています。表示されている 2 つのワードをテキストフィールドにご入力ください。

BBCode: OFF
スマイリー: OFF
トピックのレビュー
   

ファイルを添付します

展開ビュー トピックのレビュー: クライアントが自サーバーにはいってもすぐに強制切断される現象が続いています。

Re: クライアントが自サーバーにはいってもすぐに強制切断される現象が続いています。

投稿記事 by rirubear » 2017年12月07日(木) 10:31

トピ主です。
少し前のトピックになってしまいましたが、こちら解決しました。
報告としては、回線をJCOMからNUROに変更することで解決しました。

まとめとしてはJCOMの回線はマインクラフトのサーバー運営に適していないと思います。

Re: クライアントが自サーバーにはいってもすぐに強制切断される現象が続いています。

投稿記事 by rirubear » 2017年10月23日(月) 22:29

トピ主です。
試しに他者が運営しているサーバーにはいってみたところ、極端にラグかったり、さいあくの場合まったくインできない状況になっていました。
しかし、他のWebサイトの閲覧は通常の速度で問題なくおこなうことができています。

もしかしたらマインクラフトを通した通信(上り・下り)含めて何かしらの障害が起きているのかなとは予測しましたが、
だからといって具体的な改善点がわからない状態でいます。
どなたか知識のある方がいましたら、よろしくお願いします<m(__)m>

Re: クライアントが自サーバーにはいってもすぐに強制切断される現象が続いています。

投稿記事 by rirubear » 2017年10月23日(月) 17:12

トピ主です。
特定のクライアントのみではなく、全クライアントで障害が発生します。

昨日の20時頃に障害が改善されたのですが(原因不明のまま)、今日の16時頃からまた同じ障害が発生しました。
詳しい障害の発生状況は以下のとおりです。

・サーバーに5人接続していた。
・あるタイミング(16時前後)から、新規にサーバーに接続した人が、チャットも見れないまま強制切断されるようになった。
 (すでに接続していた人には障害が発生していません。)
・接続していた人も接続しなおすと障害が発生して強制切断されるようになる。

こんな感じです。
原因が不明でどうしていいかわからない状態です。
ちなみに強制切断が発生したタイミングで、サーバーやPCの設定は特に変更しておりません。

Re: クライアントが自サーバーにはいってもすぐに強制切断される現象が続いています。

投稿記事 by elise_blacklab » 2017年10月22日(日) 16:50

実際私も低速回線の頃サーバにお邪魔してTT付近で接続が安定しなくなったことがあったので,クライアント側の問題も考えられます.
特定のクライアントのみ問題が発生する場合はクライアント側の環境情報の記載も必要です.

クライアントが自サーバーにはいってもすぐに強制切断される現象が続いています。

投稿記事 by rirubear » 2017年10月22日(日) 16:20

トピック質問失礼いたします。
自サーバーにクライアントが接続しても、
『Internal Exception: java.io.IOException: 既存の接続はリモートホストに強制的に切断されました。』
のエラーが出てすぐに強制的に切断されてしまう症状が10月20日の14時頃から続いています。

■細かい症状
★サーバーホスト側
・ホストは問題なくサーバーに接続できている。
・インターネットも問題なく接続されている。
・XXXがサーバーに接続した場合、「XXXが接続しました。」という表示は出てくるが、その後すでに「XXXが切断しました。」という表示が出てくる。

★クライアント側から聞いた話
・サーバーに接続した瞬間からひどいラグが発生する。
・複数あるワールドの中で比較的データ量が少ないワールドだと落とされることはないが、データ量が多いメインワールドに移動すると、しばらくしてから強制切断される。
・サーバーの BungeeTablistPlus に表示されているping値が1300を記録している。
・クライアント側のPCからサーバーのグローバルIPにpingを送信してもらうと、『損失=0, 最小=42ms, 最大=195ms, 平均=90ms』の結果が出る。

■試してみて効果がなかった改善策
・ルーターの再起動
・ルーターからPCを接続しているケーブルLANを抜いて再度差し込む
・パブリックネットワーク/プライベートネットワークの確認(プライベートネットワークに設定)
・ファイアウォールの一時的な無効化
・WindowsUpdateの実行
・ネットワークアダプターのアップデート
・プロパイダ(JCOM)に問い合わせる
(内容)
 ・特に大きな通信障害はおこっていない
 ・通信制限はかけていない
 ・プロパイダ~ルーター間の接続に特に問題は発生していない
 ・JCOMが推奨する固定用プライベートIPに変更して、そのIPでポート開放をおこなっても効果なし
・spigot-1.12.2.jarのビルドをしなおす
・プラグインを全部抜いてサーバーを再起動
・同ドライブ別フォルダで別サーバー(プラグイン0のバニラ状態)を立ち上げる

■環境
【スペックなど】
OS:Windows 10 Pro
CPU:Intel Core i7 CPU 950 @3.07GHz, 3060Mhz
メモリ:20GB
利用可能な物理メモリ:10.6GB
Bungee割当メモリ:Xms2G Xmx5G
Spigot割当メモリ:Xms5G Xmx13G
【回線速度】
ピン:20 ms
下り:95.43 Mb/s
上り:10.00 Mb/s
測定したサイト:http://www.sokudo.jp/?&again
【サーバー構成】
・BungeeCord
[プラグイン]
BungeeMotd-1.2
BungeeTabListPlus-2.8.1
BungeeWhiteList
ProxyTickets-1.0.4
ViaVersion-1.3.0

・spigot-1.12.2
[プラグイン]
AdvancedModreq
AreaShop
AutoMessagev1.7
AutoSaveWorld
BungeeTabListPlus_BukkitBridge-2.8.1
ChestCommands
CommandSigns
CoreProtect_2.14.2
CrazyAuctions[v1.2.4]
CustomTrash_2.1
dynmap-2.5
Dynmap-WorldGuard-0.90
EntityLWC
EssentialsX-2.0.1
FarmAssist
FeatherBoard
FirstJoinPlus
GriefPrevention
HolographicDisplays
ImageOnMap
IronElevators
JDynmapGriefPrevention_251
Jecon-1.1.1
Jobs4.1.3
LunaChat
MCBans
Multiverse-Core-2.5.0
Multiverse-Portals-2.5.0
MyCommand
NekoWorldRegen
PermissionsEx
ProxyTicketsBukkit-1.0.4
QuickShop-0.9.35
ScriptBlockPlusv1.3.3
SecurityVillagers-2.6.0
setspawn-2.2.1
SimpleVoteListener
TreeAssist
Vault
Vehicles(8.6)
viabackwards-all-2.3.1
ViaVersion-1.3.0
votifier-1.9
VoxelSniper-5.171.0-SNAPSHOT
WorldBorder
worldedit-bukkit-6.1.7.3
worldguard-6.2.1

ページトップ

x