[1.12.1]PlayerFormLittleMaid 旧バージョン用littleMaidMob

開発したMODの公開や、見つけたMODの紹介などはこちらでどうぞ!

PlayerFormLittleMaidをマルチプレイで使用していますか?

投票は 2012年9月25日(火) 22:28 を以って終了致しました

マルチプレイで使用している
66
37%
マルチプレイをしているが使用していない
30
17%
シングルプレイしかしていない(マルチプレイそのものをしない)
84
47%
 
投票総数 : 180

  • (PostNo.279456)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by ゲスト » 2016年8月03日(水) 20:30

1.6.4 ForgeVer 9.11.1.965環境にてModchuLib・PFLM・デフォルトモデルパックを導入したところ、タイトル画面までいかずに強制終了します。
強制終了後、エラーログも出ずにそのままデスクトップまで戻ってしまいます。
タイトル画面に入る前のmodchuLibとモデルパックの確認画面(?)はでますが・・・。

ModchuLibおよびPFLM本体、デフォルトモデルパックを外すと起動することができます。

何か導入方法を間違えているのでしょうか?
ゲスト
ID:f23f02d6
 

  • (PostNo.279460)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by ゲスト » 2016年8月03日(水) 21:36

↑のものです。
デフォルトモデルパックだけ外してタイトル画面までいけたので、デフォルトモデルパックが原因のようです・・・。
ですが、それ以外がわかりません。対処法があれば教えてください・・・・。
ゲスト
ID:f23f02d6
 

  • (PostNo.279461)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by モドチュー » 2016年8月03日(水) 21:42

ゲスト さんが書きました:1.6.4 ForgeVer 9.11.1.965環境にてModchuLib・PFLM・デフォルトモデルパックを導入したところ、タイトル画面までいかずに強制終了します。
強制終了後、エラーログも出ずにそのままデスクトップまで戻ってしまいます。
タイトル画面に入る前のmodchuLibとモデルパックの確認画面(?)はでますが・・・。

ModchuLibおよびPFLM本体、デフォルトモデルパックを外すと起動することができます。

何か導入方法を間違えているのでしょうか?

minecraftランチャーの Edit Profile ボタンを押した時の設定画面にある
Launcher Visibilityにチェック、その右にある項目を Keep the launcher open にしてSave Profileを押してから
minecraftを起動し直してみてminecraft Launcherにエラーが出ているか確認して下さい。
それ以外の方法で、configフォルダにある Modchu_ModchuLib.cfg を開き、
デフォルトfalseとなっている debugLogMessage=true に書き換えて保存してからminecraftを起動する事によって作成されるようになるログファイルModchuDebug.logの中身を
http://pastebin.com/
などを利用して教えていただけると問題がわかる可能性があります。
アバター
モドチュー
ID:c6d64c26
ラピスラズリ収集家
 
記事: 1221
登録日時: 2011年9月07日(水) 02:33

  • (PostNo.279465)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by ゲスト » 2016年8月03日(水) 21:56

>>minecraftランチャーの Edit Profile ボタンを押した時の設定画面にある
Launcher Visibilityにチェック、その右にある項目を Keep the launcher open にしてSave Profileを押してから
minecraftを起動し直してみてminecraft Launcherにエラーが出ているか確認して下さい。

launcherにエラーはでていませんでした。

>>それ以外の方法で、configフォルダにある Modchu_ModchuLib.cfg を開き、
デフォルトfalseとなっている debugLogMessage=true に書き換えて保存してからminecraftを起動する事によって作成されるようになるログファイルModchuDebug.logの中身を
http://pastebin.com/
などを利用して教えていただけると問題がわかる可能性があります。

http://pasted.co/da6243e1
このURLで見れます。お願いします。
ゲスト
ID:f23f02d6
 

  • (PostNo.279466)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by ペコリン » 2016年8月03日(水) 21:58

モドチュー さんが書きました:ModchuLib_mc1_5_2-1_10_2-v16b
内部コード調整・追加など。

PlayerFormLittleMaid_mc1_5_2-1_10_2-v33b
GuiModelListSelectでの処理改善、ページボタン・カラーボタンの追加。

MultiModel_DefaultModelSet_mc1_5_2-1_10_2-v27c
MultiModelSet_mc1_5_2-1_10_2-v27a
盾装備時の向き調整。Customモデル調整。

テスト公開 セヤナーモデル更新
ダウンロード記事


ペコリン さんが書きました:実害はほぼないのですが、一応報告を。
三人称視点でオフハンドに持っている盾でガードした時、上下反転してしまいます。
2016-07-24_22.25.22.png

また、両手に盾を持ってガードした時、通常ならメインハンドの盾しか前に出ませんが、PFLM導入状態ではオフハンドの盾も前に出ます。
2016-07-24_22.25.38.png

マルチでは未検証です。

環境
Minecraftバージョン1.9.4
forge-1.9.4-12.17.0.1976
ModchuLib_mc1_5_2-1_10_2-v16a
PlayerFormLittleMaid_mc1_5_2-1_10_2-v33a
MultiModel_DefaultModelSet_mc1_5_2-1_10_2-v27b
MultiModelOtherCustomModelEnemy_v1a
MultiModelOtherCustomModelPassive_v1c
MultiModelSet_mc1_5_2-1_9-v27

報告ありがとうございます。修正版を出しました。


修正ありがとうございます。
正常に表示されることを確認しました。
通常のプレイではまず気にならないのですが、四角くない自作の盾を作ってガードした時に発覚した次第でして。

あと今回の更新で、座った・寝た状態のまま移動できていたのが修正されたのでしょうか。
村人をメイドさんにするMODを好き勝手に作ってますん
アバター
ペコリン
ID:60ac8b6a
大工さん
 
記事: 65
登録日時: 2016年5月01日(日) 20:56

  • (PostNo.279473)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by モドチュー » 2016年8月03日(水) 23:05

ゲスト さんが書きました:>>minecraftランチャーの Edit Profile ボタンを押した時の設定画面にある
Launcher Visibilityにチェック、その右にある項目を Keep the launcher open にしてSave Profileを押してから
minecraftを起動し直してみてminecraft Launcherにエラーが出ているか確認して下さい。

launcherにエラーはでていませんでした。

>>それ以外の方法で、configフォルダにある Modchu_ModchuLib.cfg を開き、
デフォルトfalseとなっている debugLogMessage=true に書き換えて保存してからminecraftを起動する事によって作成されるようになるログファイルModchuDebug.logの中身を
http://pastebin.com/
などを利用して教えていただけると問題がわかる可能性があります。

http://pasted.co/da6243e1
このURLで見れます。お願いします。

1.6.4バージョンのlittleMaidMobへの連携機能の不具合のようです。
暫定としまして、以下の旧バージョンまで下げるかまたは修正版を待つかPFLM導入をあきらめるかの判断をして下さい。
ModchuLib_mc1_6_2-1_8_9-v14
PlayerFormLittleMaid_mc1_6_2-1_8_9-v32
MultiModel_DefaultModelSet_mc1_6_2-1_8_9-v26
(MultiModelSet_mc1_6_2-1_8_9-v26)
アバター
モドチュー
ID:c6d64c26
ラピスラズリ収集家
 
記事: 1221
登録日時: 2011年9月07日(水) 02:33

  • (PostNo.279474)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by ゲスト » 2016年8月03日(水) 23:22

素早い対応どうもありがとうございました。
過去Verが無事導入できたので、そちらを楽しむことにします!
ありがとうございました!
ゲスト
ID:f23f02d6
 

  • (PostNo.279500)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by モドチュー » 2016年8月04日(木) 08:37

ModchuLib_mc1_5_2-1_10_2-v16c
1.6.4LMM対応関連不具合修正。
(dev版には問題ない為、dev版更新はしません)
アバター
モドチュー
ID:c6d64c26
ラピスラズリ収集家
 
記事: 1221
登録日時: 2011年9月07日(水) 02:33

  • (PostNo.279560)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by モドチュー » 2016年8月04日(木) 22:36

テスト公開 CustomModel Plate

説明:
ぺらいテクスチャ一枚なモデルです。
配布zipそのまま導入すると単色ベタな四角ペラモデルが使用できます。
このモデルは主にテクスチャを改造して使用する事を想定されており、
改造後のzipファイルであれば再配布が可能です。(テクスチャの著作権にご注意下さい)
テクスチャ以外にCustomModelのcfgファイルの改造も許可します。

ダウンロード
MultiModel_CustomModel_Plate_v1[2016/08/04]

modsフォルダに入れると導入できます。
2016-08-04_22.02.26_.png


CustomModelのcfgファイルの改造について
・モデルの大きさが1ブロック分くらいで小さいのをなんとかしたい場合
mainScale = 0.25F, 0.25F, 0.25F
の0.25Fの数字を大きくする。0.5Fで2倍、1.0Fで4倍。

他の項目について知りたい方が居れば答えます。
アバター
モドチュー
ID:c6d64c26
ラピスラズリ収集家
 
記事: 1221
登録日時: 2011年9月07日(水) 02:33

  • (PostNo.280037)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob の質問

投稿記事by gest » 2016年8月09日(火) 17:55

こういったサイトを利用することが初めてですので場違いなどございましたら失礼します。

マルチでのことなのですが
モデルの [結月ゆかりモデル] と [弦巻マキモデル] を使用しています。
プレイヤーリトルメイドmodで容姿を マルチ用スキン作成手順 結月ゆかりモデルは反映できたのですが
弦巻マキモデルはどうやっても反映できません。
結月ゆかりモデルは [モデルパック] の方からダウンロードしたのですが弦巻マキモデルは別サイトから入れたものなので
もしかしたらそれが原因で反映されていないのかもしれません、あくまで自論ですか…
いつぞやの動画様で この2人のモデルを使用してマルチをしていた方がいらっしゃったので。可能だとは思いますが。

プレイヤーリトルメイドを使って [結月ゆかりモデル] [弦巻マキモデル] を使用することは可能でしょうか?

あと、サイトの方でもあった [マルチ用スキン作成手順] の方法もいまいち理解しておりません。
[3. 左にあるボタンでメイドモデル、色、アーマーモデルを選択し、MultiPngSaveボタンを押します。]とあるのも
項目をいくら探しても弦巻マキモデルは出てきません。

verは1.7.10です。このバージョンでできないのでしたらどのバージョンができるか教えていただけると幸いです

私自身全く知識がないですができるだけの情報は書いておきます。
どなたか教えてくださるかた返信お待ちしております
gest
ID:fbbe15ed
 

  • (PostNo.280070)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob の質問

投稿記事by ペコリン » 2016年8月09日(火) 22:08

gest さんが書きました:こういったサイトを利用することが初めてですので場違いなどございましたら失礼します。

マルチでのことなのですが
モデルの [結月ゆかりモデル] と [弦巻マキモデル] を使用しています。
プレイヤーリトルメイドmodで容姿を マルチ用スキン作成手順 結月ゆかりモデルは反映できたのですが
弦巻マキモデルはどうやっても反映できません。
結月ゆかりモデルは [モデルパック] の方からダウンロードしたのですが弦巻マキモデルは別サイトから入れたものなので
もしかしたらそれが原因で反映されていないのかもしれません、あくまで自論ですか…
いつぞやの動画様で この2人のモデルを使用してマルチをしていた方がいらっしゃったので。可能だとは思いますが。

プレイヤーリトルメイドを使って [結月ゆかりモデル] [弦巻マキモデル] を使用することは可能でしょうか?

あと、サイトの方でもあった [マルチ用スキン作成手順] の方法もいまいち理解しておりません。
[3. 左にあるボタンでメイドモデル、色、アーマーモデルを選択し、MultiPngSaveボタンを押します。]とあるのも
項目をいくら探しても弦巻マキモデルは出てきません。

verは1.7.10です。このバージョンでできないのでしたらどのバージョンができるか教えていただけると幸いです

私自身全く知識がないですができるだけの情報は書いておきます。
どなたか教えてくださるかた返信お待ちしております


結月ゆかりモデルはデフォルトモデルパックに含まれていますので、ここのトピックのMOD導入だけで使用可能です。
しかし、弦巻マキモデルに限らずLittleMaidMob用のモデルは、PFLMで直接読み込むことはできません。
LittleMaidMob MODが読み込んだモデルを、PFLMが読み込むという形で使用することになります。
従って、マイクラ本体のバージョンに対応したLittleMaidMob MODを導入する必要があります。
特に細かい設定等は必要なく、自動的に連携してモデルが読み込まれます。

一手間かければLittleMaidMob MODを導入しなくてもPFLMで読み込むことはできるのですが。
村人をメイドさんにするMODを好き勝手に作ってますん
アバター
ペコリン
ID:60ac8b6a
大工さん
 
記事: 65
登録日時: 2016年5月01日(日) 20:56

  • (PostNo.280181)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by gest » 2016年8月11日(木) 03:24

posting.php?mode=reply&f=13&t=2073#pr280070
結月ゆかりモデルはデフォルトモデルパックに含まれていますので、ここのトピックのMOD導入だけで使用可能です。
しかし、弦巻マキモデルに限らずLittleMaidMob用のモデルは、PFLMで直接読み込むことはできません。
LittleMaidMob MODが読み込んだモデルを、PFLMが読み込むという形で使用することになります。
従って、マイクラ本体のバージョンに対応したLittleMaidMob MODを導入する必要があります。
特に細かい設定等は必要なく、自動的に連携してモデルが読み込まれます。


一手間かければLittleMaidMob MODを導入しなくてもPFLMで読み込むことはできるのですが。>>

とありますがそのひと手間とは、どういった方法なのでしょうか?
詳細など教えていただけると嬉しいです。
お早い返信ありがとうございます!

後、リトルメイドmodが必要だったんですね、全く知りませんでした。
よろしければですがリトルメイドmodを入れない方法を教えていただきたいです
よろしくお願いしますm(__)m
gest
ID:fbbe15ed
 

  • (PostNo.280327)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by gest’s » 2016年8月13日(土) 09:22

数日前、上の通りなのですが。

リトルメイドmod と 連携させるとうまくいくという話を聞きましたが。
自動で連携してくれるはずのmodが連携できておらず。ModelChange:Online で探しても見つかりませんでした。
なので、よろしければ、リトルメイドmodを使用しないで、マルチ作成する方法を教えていただけないでしょうか?

リトルメイドのほうではおそらく、versionがあっていないためだと思いました。
メイドには対応しているものの、スキン事態が1.6.2でストップしているので、戻す必要があるのだと思います。(あくまで私の考えですが)

それともう一つ。
マルチ用スキン作成手順でちゃんとできたりできなかったり、よくわからない点があるのでご質問させていただきます。
1.ModelChenge:Online にし、マルチ用テクスチャ出力フォルダを書き出すのは シングルでですか?マルチのほうでですか?
2.マルチ用テクスチャを出力した時に毎回 ModelChenge:Online の左に選択したものでなく、今使っているスキンが出力されるのですが (今使っているのが通常のスキンなら通常のスキン)
これは正常なのでしょうか?やり方が少し間違っているのでしょうか。私はよくわからないので、毎回Off:lineのほうで一回 出力したいスキンに設定してから
[Sava]を押し、そこからマルチ用テクスチャを出力しています。
3.マルチ鯖のクライント側に入れるmod は[PlayerFormLittleMaidFML 1.5.2~1.9用 v10a.zip]と[ModchuLib 1.5.2-1.10.2用 v16c.zip]であっていますか?

以上です。宜しければどなたかご返信ください。
gest’s
ID:12143625
 

  • (PostNo.280487)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by モドチュー » 2016年8月14日(日) 19:00

gest’s さんが書きました:数日前、上の通りなのですが。

リトルメイドmod と 連携させるとうまくいくという話を聞きましたが。
自動で連携してくれるはずのmodが連携できておらず。ModelChange:Online で探しても見つかりませんでした。
なので、よろしければ、リトルメイドmodを使用しないで、マルチ作成する方法を教えていただけないでしょうか?

リトルメイドのほうではおそらく、versionがあっていないためだと思いました。
メイドには対応しているものの、スキン事態が1.6.2でストップしているので、戻す必要があるのだと思います。(あくまで私の考えですが)

それともう一つ。
マルチ用スキン作成手順でちゃんとできたりできなかったり、よくわからない点があるのでご質問させていただきます。
1.ModelChenge:Online にし、マルチ用テクスチャ出力フォルダを書き出すのは シングルでですか?マルチのほうでですか?
2.マルチ用テクスチャを出力した時に毎回 ModelChenge:Online の左に選択したものでなく、今使っているスキンが出力されるのですが (今使っているのが通常のスキンなら通常のスキン)
これは正常なのでしょうか?やり方が少し間違っているのでしょうか。私はよくわからないので、毎回Off:lineのほうで一回 出力したいスキンに設定してから
[Sava]を押し、そこからマルチ用テクスチャを出力しています。
3.マルチ鯖のクライント側に入れるmod は[PlayerFormLittleMaidFML 1.5.2~1.9用 v10a.zip]と[ModchuLib 1.5.2-1.10.2用 v16c.zip]であっていますか?

以上です。宜しければどなたかご返信ください。

まずやりたい事がPFLMモデルとlittleMaidMob用のモデルをマルチプレイにて使用したいで合っていますか?
それでしたらまず最低限はlittleMaidMobの導入は必須となります。
(littleMaidMobを導入せずに…と書いた方はたぶんPFLM用に改造できれば、という考えだと思われ)
マルチ鯖には
littleMaidMob(+必須MOD)

クライアント側には
littleMaidMob(+必須MOD)
PlayerFormLittleMaid
ModchuLib
MultiModel_DefaultModelSet
MultiModelSet
となります。
PlayerFormLittleMaidFMLを導入したい場合はPFLMの特殊動作
(ショトカによる座る、寝る等)を反映させたい場合に限り導入が必要ですが、
その場合には鯖側にModchuLib、PlayerFormLittleMaidFMLが必要になります。
クライアントにもModchuLib、PlayerFormLittleMaidFML。
マルチ用スキンは基本的には作成する必要性はありません。
マルチプレイ時のPFLM のモデル選択 GUIの右上にあるotherPlayerボタンで他のプレイヤーの見た目を自由に設定が可能です。
相手にもPFLMを導入してもらい逆のモデル設定をしてもらうとお互いの見た目が一致します。
マルチ用スキンについて
PFLMは相手からの見た目を強制する仕様ではないのですが、半強制なら可能です。その方法がマルチ用スキンとなっています。
最低限として相手のPFLMのotherPlayer設定でOnlineModeに設定してもらう必要があります。
>>今使っているスキンが出力される
合っています。右上or右下に3ドットの追加がされている画像なら正しく出力されています。
LMM用のモデルを使用したい場合は、
マルチ用スキン作成手順の
3)通常未対応のオリジナルモデルを使用したい場合
を参考にして下さい。
アバター
モドチュー
ID:c6d64c26
ラピスラズリ収集家
 
記事: 1221
登録日時: 2011年9月07日(水) 02:33

  • (PostNo.280499)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by ペコリン » 2016年8月14日(日) 20:51

ふと思ったのですが、マキさんは黄色メイドなので、
PFLMのModelSelect画面でMaidColorを「4」に指定しないと選択できません。
確認されたでしょうか。

Pageは読み込まれているモデルの数によって変わるので、どのページかは環境によります。

2016-08-14_20.46.18.png
ちょっと前のバージョンのGUIですみません


マルチ環境かなー?とは思ったのですが明記されていなかったのであえて触れませんでした。
私が書いたLMMなしで読み込ませる「一手間」は、マルチで相手からも見えるようになるものではありませんね。
村人をメイドさんにするMODを好き勝手に作ってますん
アバター
ペコリン
ID:60ac8b6a
大工さん
 
記事: 65
登録日時: 2016年5月01日(日) 20:56

  • (PostNo.283807)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by LEVIATHAN » 2016年9月23日(金) 01:07

EBLib-EL3B13-1.8.x
LittleMaidMobNX-NX5B84-1.8.x
ModchuLib_mc1_5_2-1_10_2-v16c
PlayerFormLittleMaid_mc1_5_2-1_10_2-v33b
これらを導入したのですが
PlayerFormLittleMaidだけModListに表示されません
それとも仕様で表示されないのでしょうか?
一応@を押しても何も起きませんしどうすればいいのでしょうか?
LEVIATHAN
ID:65288c05
水から上がったとこ
 
記事: 8
登録日時: 2014年6月02日(月) 15:27

  • (PostNo.283823)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by hesuke » 2016年9月23日(金) 09:22

LEVIATHAN さんが書きました:EBLib-EL3B13-1.8.x
LittleMaidMobNX-NX5B84-1.8.x
ModchuLib_mc1_5_2-1_10_2-v16c
PlayerFormLittleMaid_mc1_5_2-1_10_2-v33b
これらを導入したのですが
PlayerFormLittleMaidだけModListに表示されません
それとも仕様で表示されないのでしょうか?
一応@を押しても何も起きませんしどうすればいいのでしょうか?


マルチモデルパックは入れましたか?
それも必須Modですよ。
hesuke
ID:d1999f65
木を殴ってる
 
記事: 13
登録日時: 2016年6月20日(月) 08:40

  • (PostNo.283854)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by LEVIATHAN » 2016年9月23日(金) 17:26

hesuke さんが書きました:
LEVIATHAN さんが書きました:EBLib-EL3B13-1.8.x
LittleMaidMobNX-NX5B84-1.8.x
ModchuLib_mc1_5_2-1_10_2-v16c
PlayerFormLittleMaid_mc1_5_2-1_10_2-v33b
これらを導入したのですが
PlayerFormLittleMaidだけModListに表示されません
それとも仕様で表示されないのでしょうか?
一応@を押しても何も起きませんしどうすればいいのでしょうか?


マルチモデルパックは入れましたか?
それも必須Modですよ。


全部導入したところ出来ました!ありがとうございます
LEVIATHAN
ID:65288c05
水から上がったとこ
 
記事: 8
登録日時: 2014年6月02日(月) 15:27

  • (PostNo.286183)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by miso501 » 2016年10月22日(土) 15:16

いつもPFLMの更新お疲れ様です

現在PFLMの開発環境を構築しようとしているのですが、修正方法のわからないエラーが多数残ったまま手詰まっている状態です。以下が現在の開発環境です

MCP8.05(Minecraft1.6.2)
Java SE Development Kit 7 Update 80
Java 7 Update 80

Modloader
LMMおよび前提のMMMLib
PFLMの関連ファイル
↓導入手順:
viewtopic.php?f=13&t=2073&start=1080#p221685
を参考に
Modchulibのjarファイルを解凍、中身のmodchuおよびassetsフォルダをmcp/src/minecraft下にコピーし

src\minecraft\modchu\lib\modloader
src\minecraft\mod_Modchu_ModchuLibForModLoader.java
src\minecraft\modchu\lib\common\
src\minecraft\modchu\lib\forge\
のファイルおよびフォルダの数字の162を含まないもの(152_172等ならその範囲内に162を含まないもの)
を消去

②MultiModel_DefaultModelSetとMultiModelSetをそれぞれ解凍し、中身のassetsをsrc\minecraft\assets下に、modchuを\mcp\src\minecraft下にコピー、統合

③同様の手順でPFLMも解凍、中身のassets、modchuフォルダを\mcp\src\minecraft下にコピー、統合

④Forgeは未導入なのでforge関連のフォルダをすべて消去


この状態で、今現在「~で未定義です」「フィールドではありません」等の700以上のエラーが解決できない状態にあります
フィールドなどの一部には「field_"数値"」といった形に変えて定義されているものもあったので
https://gitlab.prok.pw/Mirrors/fml/blob/ab52901b8b47a525e2719cf280327e97bad7f91e/conf/fields.csv

上記spoilerのリンクを参考に置換してみもしたのですが、「LimbSwingAmount」など置換してもそもそも未定義のものもあり、解決できていないものもあります。

自分の知識が未熟なゆえ完全に手詰まりな状態で、可能であればお力添えをいただければと存じます

以下環境構築の目的等
一応今回PFLMの環境構築を行っているのは、今現在使っている自作マルチモデルをPFLM単体で(LMM未導入の状態)で使えるようにできないか模索するのが目的です。ご存知の通り現在LMMが対応しているのは1.9まで(Vercleneが移行してくださったLittleMaidReengaged)で、1.10にはまだ対応していない、つまり、普段PFLMに合わせて導入するLMMで読み込むマルチモデルが読み込めない状態です。ならLMMが対応するまで待てばいいのではないかっというのが一番簡単な話なのですが、そこは興味本位、できるならやってみたいという単純な考えです。すみません。


長文失礼しました

追記>>マイクラのバージョンの記載を忘れていました
   Minecraft1.6.2です。
アバター
miso501
ID:df45a460
石掘り
 
記事: 141
登録日時: 2013年6月29日(土) 18:14

  • (PostNo.286292)

Re: [1.10.2]PlayerFormLittleMaid 旧バージョン用littleMaidMob

投稿記事by モドチュー » 2016年10月23日(日) 20:52

miso501 さんが書きました:いつもPFLMの更新お疲れ様です

現在PFLMの開発環境を構築しようとしているのですが、修正方法のわからないエラーが多数残ったまま手詰まっている状態です。以下が現在の開発環境です

MCP8.05(Minecraft1.6.2)
Java SE Development Kit 7 Update 80
Java 7 Update 80

Modloader
LMMおよび前提のMMMLib
PFLMの関連ファイル
↓導入手順:
viewtopic.php?f=13&t=2073&start=1080#p221685
を参考に
Modchulibのjarファイルを解凍、中身のmodchuおよびassetsフォルダをmcp/src/minecraft下にコピーし

src\minecraft\modchu\lib\modloader
src\minecraft\mod_Modchu_ModchuLibForModLoader.java
src\minecraft\modchu\lib\common\
src\minecraft\modchu\lib\forge\
のファイルおよびフォルダの数字の162を含まないもの(152_172等ならその範囲内に162を含まないもの)
を消去

②MultiModel_DefaultModelSetとMultiModelSetをそれぞれ解凍し、中身のassetsをsrc\minecraft\assets下に、modchuを\mcp\src\minecraft下にコピー、統合

③同様の手順でPFLMも解凍、中身のassets、modchuフォルダを\mcp\src\minecraft下にコピー、統合

④Forgeは未導入なのでforge関連のフォルダをすべて消去


この状態で、今現在「~で未定義です」「フィールドではありません」等の700以上のエラーが解決できない状態にあります
フィールドなどの一部には「field_"数値"」といった形に変えて定義されているものもあったので
https://gitlab.prok.pw/Mirrors/fml/blob/ab52901b8b47a525e2719cf280327e97bad7f91e/conf/fields.csv

上記spoilerのリンクを参考に置換してみもしたのですが、「LimbSwingAmount」など置換してもそもそも未定義のものもあり、解決できていないものもあります。

自分の知識が未熟なゆえ完全に手詰まりな状態で、可能であればお力添えをいただければと存じます

以下環境構築の目的等
一応今回PFLMの環境構築を行っているのは、今現在使っている自作マルチモデルをPFLM単体で(LMM未導入の状態)で使えるようにできないか模索するのが目的です。ご存知の通り現在LMMが対応しているのは1.9まで(Vercleneが移行してくださったLittleMaidReengaged)で、1.10にはまだ対応していない、つまり、普段PFLMに合わせて導入するLMMで読み込むマルチモデルが読み込めない状態です。ならLMMが対応するまで待てばいいのではないかっというのが一番簡単な話なのですが、そこは興味本位、できるならやってみたいという単純な考えです。すみません。


長文失礼しました

追記>>マイクラのバージョンの記載を忘れていました
   Minecraft1.6.2です。

ModLoader環境の場合はModchuLibにある forge と名の付くフォルダを削除して下さい。
lmm/forge もあるはずです。
参考にされている場所はソースファイルをそのまま導入する方法ですが、
現在dev版の公開がありますのでそのjarを開発環境に追加する方法の方が楽なのでおすすめです。
アバター
モドチュー
ID:881a313e
ラピスラズリ収集家
 
記事: 1221
登録日時: 2011年9月07日(水) 02:33

1つ前へ次へ

Return to MOD 公開/紹介

x