銃火器プラグインを使っていて1.9.xのバグの為にアップデートしたくないサーバー運営者様へ

サーバー個別、マルチサーバー全体の話題など自由にご活用下さい
  • (PostNo.273139)

銃火器プラグインを使っていて1.9.xのバグの為にアップデートしたくないサーバー運営者様へ

投稿記事by Dotoo » 2016年5月20日(金) 01:32

すごくニッチな話題ですいません。

各サーバー運営者様の中にはCrackshot等を始め、Projectileをプレイヤーから発射して云々といった事をされている方も多いと思いますが、
ご存知の通りバージョン1.9.xでこれを行うと、entityがプレイヤーから2~5ブロック以内にいる+ある角度でそれを狙って雪球などを投げると
プレイヤーから発射された雪球などがプレイヤーの頭あたりに直撃して自爆してしまうという、小さいけれども一部の方にとっては致命的なバグが存在します。
ですからいわゆる「銃サーバー」などは1.9.xで運営する事は不可能でしたし、例えば建築サーバーなどでも雪合戦で遊ぶ事は難しい状態です。
しかもMojangはこの問題を当面まともに修正する予定は無さそうです。

この一部の人にとっては致命的なバグですが、これをプラグイン一つで解決した人が現れました。以下のURLからDLが可能です。
http://dev.bukkit.org/bukkit-plugins/projectilebugfix/
ソースコードも公開なさっています。Javaの知識があればご自身で挙動を変える事も可能です。
https://github.com/DanyBv/ProjectileBugFix

恐らくこの問題については海外を含め殆ど情報が出回っていない為、このケースに該当するサーバー運営者様にとっては
サーバー運営上死活問題だと思いましたので、自分へのメモを兼ねてここに投稿させて頂きます。
アバター
Dotoo
ID:eaeeeb72
金掘り
 
記事: 411
登録日時: 2012年11月21日(水) 15:20

  • (PostNo.273902)

Re: 銃火器プラグインを使っていて1.9.xのバグの為にアップデートしたくないサーバー運営者様へ

投稿記事by はらちゅー » 2016年5月28日(土) 20:59

素晴らしいご報告です。多くのサーバーが1.9へ対応できることでしょう(vv )

多分これに苦しんでる人は私含め結構いると思いますのでこのメモを広めたいところですね。
pvpサーバー構築に向けてぼちぼち歩いている身。
こういうときplugin作れる人ってすごいなーと
アバター
はらちゅー
ID:258a9155
石掘り
 
記事: 110
登録日時: 2015年2月04日(水) 23:33
お住まい: みんなのマザーボードの一部


Return to マルチサーバー雑談

x