ツールの作成をお願い致します。

クライアント/サーバーMODの開発に関する話題、技術交換はこちらで。質問は質問フォーラムへお願いします。
  • (PostNo.242644)

ツールの作成をお願い致します。

投稿記事by PvP厨 » 2015年8月11日(火) 17:43

MODを非対応のバージョンに簡単に対応させる
ツール作って下さい。
僕的には、1.6.4から1.7.10に対応させる
物が欲しいです。お願いします。
~サーバー運営中~
画像
PvP厨
ID:f67b0482
木を殴ってる
 
記事: 24
登録日時: 2015年7月28日(火) 11:52
お住まい: 教えるかよ

  • (PostNo.242669)

Re: ツールの作成をお願い致します。

投稿記事by ゲスト » 2015年8月11日(火) 21:03

結論から言うと無理です
昔のトピックにも同じことをを言ってる人がいたのですがマインクラフトの場合バージョンによって内部構成が思いっきり違うので、バージョンがひとつでも違えば1000以上のエラーが発生するみたいなので、ツールではまず無理です、マインクラフトのプログラミングはそういうものです。

スキン等を新スキンに変える編集ツールがあるじゃんと思われるかと思いますがあれぱただコピーして貼り付けるだけなので非常に簡単です、MODを制作する場合一文字でも打ち間違えてるとエラーが発生し起動しません(これはミスしてるプログラムの場所によりますが)

もしそのようなツールを制作してもすべてのエラーを修復できず動かすのは無理でさ、むしろツールを作る方が手間がかかります、無意味です

もう一度言います無理です、諦めてください
ゲスト
ID:5f84d3cc
 

  • (PostNo.243117)

Re: ツールの作成をお願い致します。

投稿記事by Hayabusa58 » 2015年8月15日(土) 02:24

どうしても対応させたい、と思ったのであれば自分でJavaを学びソースを書き換える(公開されていれば)という方法があります。
複雑な動作をするMODは難しいですが簡単なアイテム追加系程度なら出来るかもしれません。
ですが現実的にそのようなツールを作るよりはるかに簡単かと。
サイン 【利用者の方へ】: フォーラムご利用前に:【必読】投稿ガイドライン / 質問を投稿する前に:【必読】質問の仕方について
【私について】: グローバルモデレータです / 連絡: h_ya58@Twitterまたはモデレータ宛PM に / 自作MODの公開トピックです
アバター
Hayabusa58
ID:37960fa8
レッドスト―ン掘り
 
記事: 684
登録日時: 2014年5月01日(木) 21:49
お住まい: おふとん


Return to 開発関連

x