ページ 11

ツールの作成をお願い致します。

投稿記事Posted: 2015年8月11日(火) 17:43
by PvP厨
MODを非対応のバージョンに簡単に対応させる
ツール作って下さい。
僕的には、1.6.4から1.7.10に対応させる
物が欲しいです。お願いします。

Re: ツールの作成をお願い致します。

投稿記事Posted: 2015年8月11日(火) 21:03
by ゲスト
結論から言うと無理です
昔のトピックにも同じことをを言ってる人がいたのですがマインクラフトの場合バージョンによって内部構成が思いっきり違うので、バージョンがひとつでも違えば1000以上のエラーが発生するみたいなので、ツールではまず無理です、マインクラフトのプログラミングはそういうものです。

スキン等を新スキンに変える編集ツールがあるじゃんと思われるかと思いますがあれぱただコピーして貼り付けるだけなので非常に簡単です、MODを制作する場合一文字でも打ち間違えてるとエラーが発生し起動しません(これはミスしてるプログラムの場所によりますが)

もしそのようなツールを制作してもすべてのエラーを修復できず動かすのは無理でさ、むしろツールを作る方が手間がかかります、無意味です

もう一度言います無理です、諦めてください

Re: ツールの作成をお願い致します。

投稿記事Posted: 2015年8月15日(土) 02:24
by Hayabusa58
どうしても対応させたい、と思ったのであれば自分でJavaを学びソースを書き換える(公開されていれば)という方法があります。
複雑な動作をするMODは難しいですが簡単なアイテム追加系程度なら出来るかもしれません。
ですが現実的にそのようなツールを作るよりはるかに簡単かと。