【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

サーバーMODやBUKKITのプラグインなどの公開/紹介を専門に行うフォーラムです。クライアントMODと組み合わせ必須の物はMOD公開/紹介フォーラムで公開してください。
フォーラムルール
クライアントMODと対にして使用する物は極力 MOD 公開/紹介 フォーラムにて公開するようお願いします。
本フォーラムではサーバーへの適用をメインとするサーバーMOD、プラグインを取り扱います。
不明な点は管理人ecolightまでお問い合わせ下さい。
  • (PostNo.165213)

【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by yoshi435 » 2014年3月23日(日) 18:18

更新履歴:
2014/06/13: 使用できるコマンドの一覧を追加。
2014/07/25: 動画のリンクが切れていたので別の動画に変更。
このプラグインは動作にあたりJava 7以降が必要となります。
返信は基本的に出来ません。ご了承ください。

どうも、yoshi435です。
今回は、SwornGunsという銃火器プラグインを紹介します。
(これは、私が作成したプラグインではありません。)

PVPGunPlusがBANされた後、dmulloy2氏とGarretSidzaka氏が新しく作った
銃火器プラグインです。
(実は結構前からあったが気づいていない方が多そうなのでトピックを立てました。)
PVPGunPlusの設定ファイルは大抵の場合、そのまま使えます

どんなプラグインかの動画。 (私が作成したものではありません)



プラグインは安定版だとバグが多少あるので、開発版をおすすめします。

SwornGuns: http://dev.bukkit.org/bukkit-plugins/swornguns/
SwornGunsの開発版: http://ci.minesworn.com/job/SwornGuns/
SwornGunsのソースコード: https://github.com/dmulloy2/SwornGuns/
SwornGunsの最新開発版※1: http://ci.minesworn.com/job/SwornGuns/lastSuccessfulBuild/artifact/target/SwornGuns.jar
※1 このリンクからダウンロードすると常に最新版がダウンロードされます。

コマンド
コード: 全て選択
/swornguns [guns] help (コマンドの一覧を表示します。)
/swornguns [guns] reload (銃のコンフィグをリロードするコマンドです。)
/swornguns [guns] toggle (銃を発射できないようにする/出来るようにする)
/swornguns [guns] list (銃の一覧を表示するコマンドです。)

SwornGunsのパーミッション
コード: 全て選択
swornguns.reload /guns reload (設定をリロードするときのパーミッション)
swornguns.fire.銃の名前 (銃を使用可能にするかのパーミッション、needspermission=trueにしている場合のみ

パーミッションの例
コード: 全て選択
rOCKETLAUncher = "swornguns.fire.rocketlauncher"
pistol = "swornguns.fire.pistol"

プラグインの導入方法
コード: 全て選択
1. SwornGunsをダウンロードします。
2. ダウンロードしたSwornGuns.jarを "サーバーフォルダ/plugins" にコピーします。
3. サーバーが起動している場合は再起動、していない場合はサーバーを起動します。
4. Enjoy!


現在、CrackShotが有名ですが、こちらも試してみては?
最後に編集したユーザー yoshi435 [ 2014年7月25日(金) 18:23 ], 累計 14 回
最近は、テクニックや裏ワザ公開することが多いですね。
銃撃鯖は断念してしまいました。(泣)
AMIDSTの日本語版も作るかも(更新はできないがw)
アバター
yoshi435
ID:0d621c47
大工さん
 
記事: 63
登録日時: 2013年1月27日(日) 06:17

  • (PostNo.177281)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by fzii0204 » 2014年6月11日(水) 16:04

どうやったらサーバーに導入できますか?SwornGunsってのは :agd:
fzii0204
ID:fc577f83
木を殴ってる
 
記事: 19
登録日時: 2014年3月01日(土) 16:24

  • (PostNo.177286)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by gintora1125 » 2014年6月11日(水) 16:19

fzii0204 さんが書きました:どうやったらサーバーに導入できますか?SwornGunsってのは :agd:

SwornGunsのバケツプラグインのURLが見えないんですかね…導入したいのであればそのURLから飛び、ダウンロードすればいいんではないでしょうかね。
SilverSwordOnlineサーバーの管理人です。サーバーは↓
画像
スカイブロックも作ってます。トピック→http://forum.minecraftuser.jp/viewtopic.php?f=10&t=19416
MODも作ってます。トピック→http://forum.minecraftuser.jp/viewtopic.php?f=13&t=26744
アバター
gintora1125
ID:96e82791
石炭掘り
 
記事: 157
登録日時: 2013年12月29日(日) 12:50
お住まい: SilverSwordOnline

  • (PostNo.177302)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by fzii0204 » 2014年6月11日(水) 18:04

いれたのですがアイテム欄から銃に対応したものをとっても銃になりません
fzii0204
ID:fc577f83
木を殴ってる
 
記事: 19
登録日時: 2014年3月01日(土) 16:24

  • (PostNo.177329)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by fzii0204 » 2014年6月11日(水) 21:01

というか入れたはずなのに入ったという表示が出ません
fzii0204
ID:fc577f83
木を殴ってる
 
記事: 19
登録日時: 2014年3月01日(土) 16:24

  • (PostNo.177620)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by SNAKE » 2014年6月14日(土) 00:59

fzii0204 さんが書きました:というか入れたはずなのに入ったという表示が出ません

plugin verとserver verがあっているか確認してみてください
一応サーバの管理をしてます。
だけど、知識はへっぽこです
アバター
SNAKE
ID:e44e86bc
金掘り
 
記事: 420
登録日時: 2013年3月21日(木) 21:28
お住まい: japan

  • (PostNo.177653)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by エリー » 2014年6月14日(土) 10:14

fzii0204 さんが書きました:というか入れたはずなのに入ったという表示が出ません

「入れたはず」ならVarが合ってれば/pluginsで確認した時に表示される筈です
それが出来てないならソモソモ「pluginsフォルダにSwornGunsのjarファイルを入れる」だけの事が出来ていないので、銃の設定はとても無理です
確か導入した後はpluginsフォルダにjarと同名の設定用フォルダが生成されるので、その中の設定ファイルをテキストエディタで開いてやれば編集できます。
アバター
エリー
ID:cf10e15f
石掘り
 
記事: 110
登録日時: 2012年10月31日(水) 23:37
お住まい: 貴方の後ろ

  • (PostNo.177907)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by fzii0204 » 2014年6月15日(日) 17:53

ちゃんと入れたの/pluginsとうっても表示さえされません....
fzii0204
ID:fc577f83
木を殴ってる
 
記事: 19
登録日時: 2014年3月01日(土) 16:24

  • (PostNo.177910)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by fzii0204 » 2014年6月15日(日) 18:03

あと鯖起動したときに
8:01:27 [?v???I] Could not load 'plugins/SwornGuns.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: net/dmulloy2/swornguns/SwornGuns : Unsupported major.minor version 51.0
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:184)
at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305)
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230)
at org.bukkit.craftbukkit.v1_6_R3.CraftServer.loadPlugins(CraftServer.java:241)
at org.bukkit.craftbukkit.v1_6_R3.CraftServer.<init>(CraftServer.java:219)
at net.minecraft.server.v1_6_R3.PlayerList.<init>(PlayerList.java:56)
at net.minecraft.server.v1_6_R3.DedicatedPlayerList.<init>(SourceFile:11)
at net.minecraft.server.v1_6_R3.DedicatedServer.init(DedicatedServer.java:107)
at net.minecraft.server.v1_6_R3.MinecraftServer.run(MinecraftServer.java:393)
at net.minecraft.server.v1_6_R3.ThreadServerApplication.run(SourceFile:583)
Caused by: java.lang.UnsupportedClassVersionError: net/dmulloy2/swornguns/SwornGuns : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at org.bukkit.plugin.java.PluginClassLoader.findClass0(PluginClassLoader.java:80)
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:53)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:249)
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:173)
... 9 more
というのが出ます
fzii0204
ID:fc577f83
木を殴ってる
 
記事: 19
登録日時: 2014年3月01日(土) 16:24

  • (PostNo.177915)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by miyabi » 2014年6月15日(日) 18:13

fzii0204 さんが書きました:8:01:27 [?v???I] Could not load 'plugins/SwornGuns.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: net/dmulloy2/swornguns/SwornGuns : Unsupported major.minor version 51.0

Javaのバージョンが古いのが原因です。
Java6はサポートも切れているので、速やかにJava7に更新してください。
マイクラサーバを立てる前に、PCの基礎知識を身につけましょう。
サーバ管理補助ツール MCSC(Windows専用) の開発をしたり、Minecraft Modding Wikiの管理したりしてます。
アバター
miyabi
ID:05985d93
ブタ飼い
 
記事: 6788
登録日時: 2011年8月07日(日) 14:35
お住まい: さいたまさいたまさいたま!

  • (PostNo.177924)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by fzii0204 » 2014年6月15日(日) 19:02

インストールしても同じものが出てきます...
fzii0204
ID:fc577f83
木を殴ってる
 
記事: 19
登録日時: 2014年3月01日(土) 16:24

  • (PostNo.177939)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by fzii0204 » 2014年6月15日(日) 20:29

java7インストールしたはずなのにできません相変わらず
19:41:46 [?v???I] Could not load 'plugins/SwornGuns.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: net/dmulloy2/swornguns/SwornGuns : Unsupported major.minor version 51.0
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:184)
at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305)
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230)
at org.bukkit.craftbukkit.v1_6_R3.CraftServer.loadPlugins(CraftServer.java:241)
at org.bukkit.craftbukkit.v1_6_R3.CraftServer.<init>(CraftServer.java:219)
at net.minecraft.server.v1_6_R3.PlayerList.<init>(PlayerList.java:56)
at net.minecraft.server.v1_6_R3.DedicatedPlayerList.<init>(SourceFile:11)
at net.minecraft.server.v1_6_R3.DedicatedServer.init(DedicatedServer.java:107)
at net.minecraft.server.v1_6_R3.MinecraftServer.run(MinecraftServer.java:393)
at net.minecraft.server.v1_6_R3.ThreadServerApplication.run(SourceFile:583)
Caused by: java.lang.UnsupportedClassVersionError: net/dmulloy2/swornguns/SwornGuns : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at org.bukkit.plugin.java.PluginClassLoader.findClass0(PluginClassLoader.java:80)
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:53)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:249)
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:173)
... 9 more
とでます
fzii0204
ID:fc577f83
木を殴ってる
 
記事: 19
登録日時: 2014年3月01日(土) 16:24

  • (PostNo.177947)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by miyabi » 2014年6月15日(日) 21:29

fzii0204 さんが書きました:インストールしても同じものが出てきます...

Java6をアインインストールしてください。
マイクラサーバを立てる前に、PCの基礎知識を身につけましょう。
サーバ管理補助ツール MCSC(Windows専用) の開発をしたり、Minecraft Modding Wikiの管理したりしてます。
アバター
miyabi
ID:05985d93
ブタ飼い
 
記事: 6788
登録日時: 2011年8月07日(日) 14:35
お住まい: さいたまさいたまさいたま!

  • (PostNo.178035)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by fzii0302 » 2014年6月16日(月) 18:07

消したのですが同じものがまた出ます...
fzii0302
ID:fc577f83
 

  • (PostNo.178052)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by miyabi » 2014年6月16日(月) 20:29

fzii0302 さんが書きました:消したのですが同じものがまた出ます...

Javaを全てアインインストールした上で、Java7だけインストールし直して下さい。
マイクラサーバを立てる前に、PCの基礎知識を身につけましょう。
サーバ管理補助ツール MCSC(Windows専用) の開発をしたり、Minecraft Modding Wikiの管理したりしてます。
アバター
miyabi
ID:9f28f57c
ブタ飼い
 
記事: 6788
登録日時: 2011年8月07日(日) 14:35
お住まい: さいたまさいたまさいたま!

  • (PostNo.178060)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by fzii0302 » 2014年6月16日(月) 21:02

macなんですけどjavaどこでゲットできますか?
fzii0302
ID:fc577f83
 

  • (PostNo.178072)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by SNAKE » 2014年6月16日(月) 21:51

fzii0302 さんが書きました:macなんですけどjavaどこでゲットできますか?

https://java.com/ja/download/help/mac_install.xml
ここにやり方等がのっています
一応サーバの管理をしてます。
だけど、知識はへっぽこです
アバター
SNAKE
ID:b1d40bd0
金掘り
 
記事: 420
登録日時: 2013年3月21日(木) 21:28
お住まい: japan

  • (PostNo.178122)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by fzii0302 » 2014年6月17日(火) 15:36

javaというのはどういうフォルダですか macなんでわかりません
fzii0302
ID:fc577f83
 

  • (PostNo.178127)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by kabutomaru » 2014年6月17日(火) 16:42

fzii0302 さんが書きました:javaというのはどういうフォルダですか macなんでわかりません

javaをダウンロードする場所のことでしょうか?
それならば上に「ダウンロード」と書いてありますよ。(今pcが使える
状況ではないので、そのサイトを開けませんのでわかりませんが。)

後、Macなのでわかりませんとはどう言う意味でしょうか?
フォーラム名はkabutomaru
ツイッター名はてふ→Twitter
です。

作ったもの
Adventure Games
アバター
kabutomaru
ID:fe81c86c
鉄鉱掘り
 
記事: 290
登録日時: 2013年6月16日(日) 08:34

  • (PostNo.179095)

Re: 【Bukkitプラグイン】銃火器プラグインの紹介 - SwornGuns

投稿記事by youzuki » 2014年6月24日(火) 17:54

fzii0302 さんが書きました:javaというのはどういうフォルダですか macなんでわかりません

えーと、自分もmacなのでフォルダをおしえますね。
HD/システム/ライブラリ/java/JavaVirtualMachines/
でそのなかにおそらく1.6.0.jdkみたいなのがはいってます。7があればjdk1.7.0_◯◯.jdkみたいなのがあるはずです。
そのなかの1.6.0.jdkをけします。これでおそらくjava6はアンインストールされました。
ちなみに自分はjava7はjava6をけさなくても作動しました。
あともう一つjavaフォルダがあって
HD/ライブラリ/java/JavaVirtualMachines/
のなかにもjavaがあります。そのなかにも6があれば消しておいてください。

追記:macなので分かりませんって言うのは、javaのフォルダ位置がWindowsと違うからです
死んでる

以下Twitter
https://twitter.com/yukkuritakeru
アバター
youzuki
ID:9f19f6d9
石炭掘り
 
記事: 189
登録日時: 2013年10月10日(木) 20:28

次へ

Return to サーバーMOD,プラグイン 公開/紹介

x