Forgeのmod開発環境を構築できない [1.7.10]

Modding・サーバPlugin制作・ツール制作など、開発関連の質問があればこちらにお願い致します。
フォーラムルール
質問関連フォーラムで質問する時は、必ず次のトピックを一読/厳守お願い致します。
viewtopic.php?f=5&t=999
  • (PostNo.275497)

Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by sohui » 2016年6月18日(土) 18:21

Forgeのmod開発環境の構築ができません
行ったこと↓
  1. forge-1.7.10-10.13.4.1558-1.7.10-src.zipをダウンロード
  2. gradle.batの12行目と14行目の間に
    set JAVA_HOME=C:\PROGRA~1\Java\jdk1.8.0_77
    を追記
  3. call gradlew setupDecompWorkspace
    pause

    と書いたInstall.batを実行→BUILD SUCCESSFUL
  4. call gradlew runClient
    pause

    と書いたRunClient.batを実行→BUILD FAILED
RunClient.batを実行したときの実行結果↓
****************************
Powered By MCP:
http://modcoderpack.com/
Searge, ProfMobius, Fesh0r,
R4wk, ZeuX, IngisKahn, bspkrs
MCP Data version : unknown
****************************
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava
:compileJava
警告: [options] ブートストラップ・クラスパスが-source 1.6と一緒に設定されていま せん
警告1個
:processResources
:classes
:jar
:getVersionJson
:extractUserDev UP-TO-DATE
:extractNatives UP-TO-DATE
:getAssetsIndex
:getAssets
:makeStart
[ant:javac] 警告: [options] ブートストラップ・クラスパスが-source 1.6と一緒に設 定されていません
[ant:javac] 警告1個
:runClient
[17:25:39] [main/INFO] [GradleStart]: Extra: []
[17:25:39] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/祥平/.gradle/caches/minecraft/assets, --assetIndex, 1.7.10, --accessToken, {REDACTED}, --version, 1.7.10, --tweakClass, cpw.mods.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker]
[17:25:39] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[17:25:39] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[17:25:39] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
[17:25:39] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
[17:25:39] [main/INFO] [FML]: Forge Mod Loader version 7.99.36.1558 for Minecraft 1.7.10 loading
[17:25:39] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_77, running on Windows 10:amd64:10.0, installed at C:\Program Files\Java\jdk1.8.0_77\jre
[17:25:39] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
[17:25:39] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
[17:25:39] [main/INFO] [GradleStart]: Injecting location in coremod cpw.mods.fml.relauncher.FMLCorePlugin
[17:25:39] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
[17:25:39] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[17:25:39] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
[17:25:39] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[17:25:39] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[17:25:39] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[17:25:39] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[17:25:40] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!
[17:25:42] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
[17:25:42] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[17:25:42] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
[17:25:43] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[17:25:43] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.TerminalTweaker
[17:25:43] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.TerminalTweaker
[17:25:43] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[17:25:45] [main/INFO]: Setting user: Player881
[17:25:48] [Client thread/INFO]: LWJGL Version: 2.9.1
[17:25:49] [Client thread/ERROR]: Couldn't set pixel format
org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method) ~[lwjgl-2.9.1.jar:?]
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52) ~[lwjgl-2.9.1.jar:?]
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252) ~[lwjgl-2.9.1.jar:?]
at org.lwjgl.opengl.Display.createWindow(Display.java:306) ~[lwjgl-2.9.1.jar:?]
at org.lwjgl.opengl.Display.create(Display.java:848) ~[lwjgl-2.9.1.jar:?]
at org.lwjgl.opengl.Display.create(Display.java:757) ~[lwjgl-2.9.1.jar:?]
at net.minecraftforge.client.ForgeHooksClient.createDisplay(ForgeHooksClient.java:327) ~[ForgeHooksClient.class:?]
at net.minecraft.client.Minecraft.startGame(Minecraft.java:474) [Minecraft.class:?]
at net.minecraft.client.Minecraft.run(Minecraft.java:942) [Minecraft.class:?]
at net.minecraft.client.main.Main.main(Main.java:164) [Main.class:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_77]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_77]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_77]
at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_77]
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source) [start/:?]
at GradleStart.main(Unknown Source) [start/:?]
[17:25:50] [Client thread/INFO] [STDOUT]: [net.minecraft.client.Minecraft:displayCrashReport:388]: ---- Minecraft Crash Report ----
// Ouch. That hurt :(

Time: 16/06/18 17:25
Description: Initializing game

org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Display.create(Display.java:739)
at net.minecraft.client.Minecraft.startGame(Minecraft.java:494)
at net.minecraft.client.Minecraft.run(Minecraft.java:942)
at net.minecraft.client.main.Main.main(Main.java:164)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source)
at GradleStart.main(Unknown Source)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Disp lay.create(Display.java:739)
at net.minecraft.client.Minecraft.startGame(Minecraft.java:494)

-- Initialization --
Details:
Stacktrace:
at net.minecraft.client.Minecraft.run(Minecraft.java:942)
at net.minecraft.client.main.Main.main(Main.java:164)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source)
at GradleStart.main(Unknown Source)

-- System Details --
Details:
Minecraft Version: 1.7.10
Operating System: Windows 10 (amd64) version 10.0
Java Version: 1.8.0_77, Oracle Corporation
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 34419584 bytes (32 MB) / 122159104 bytes (116 MB) up to 444071936 bytes (423 MB)
JVM Flags: 0 total;
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML:
Launched Version: 1.7.10
LWJGL: 2.9.1
OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
GL Caps:
Is Modded: Definitely; Client brand changed to 'fml,forge'
Type: Client (map_client.txt)
Resource Packs: []
Current Language: ~~ERROR~~ NullPointerException: null
Profiler Position: N/A (disabled)
Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Anisotropic Filtering: Off (1)
[17:25:50] [Client thread/INFO] [STDOUT]: [net.minecraft.client.Minecraft:displayCrashReport:398]: #@!@# Game crashed! Crash report saved to: #@!@# C:\Users\sohui\modding\forge-1.7.10-10.13.4.1558-1.7.10-src\eclipse\.\crash-reports\crash-2016-06-18_17.25.50-client.txt
:runClient FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':runClient'.
> Process 'command 'C:\Program Files\Java\jdk1.8.0_77\bin\java.exe'' finished with non-zero exit value -1

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 39.317 secs

環境は以下の通りです
Widows10
Java SE Development Kit 1.8.0_77 (64bit)
Java 1.8.0_77 (32bitと64bit両方)
Forge 10.13.4.1558
Intel(R) HD Graphics バージョンは9.17.10.2828 (メーカーから出てる最新のVGA ドライバです)

普通プレイ(mod開発ではない)では、ちゃんとマインクラフトは動作します。
グラフィックスドライバはこれ以上最新にはできない感じです。
どうすればデバッグできるのでしょうか? こんな初心者でスイマセン、よろしくお願いします<(_ _)>
1.7.10もそろそろ古いのかなぁ
sohui
ID:627e7481
木を殴ってる
 
記事: 14
登録日時: 2014年11月01日(土) 15:28
お住まい: Solid State Drive

  • (PostNo.275517)

Re: Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by kegare » 2016年6月18日(土) 20:59

sohui さんが書きました:...

環境は以下の通りです
Widows10
Java SE Development Kit 1.8.0_77 (64bit)
Java 1.8.0_77 (32bitと64bit両方)
Forge 10.13.4.1558
Intel(R) HD Graphics バージョンは9.17.10.2828 (メーカーから出てる最新のVGA ドライバです)

普通プレイ(mod開発ではない)では、ちゃんとマインクラフトは動作します。
グラフィックスドライバはこれ以上最新にはできない感じです。
どうすればデバッグできるのでしょうか? こんな初心者でスイマセン、よろしくお願いします<(_ _)>

Intel(R) HD Graphics 9.17.10.2828 は、Windows 8に対応するグラフィックスドライバのようですが、
"Windows 10に対応する"最新のグラフィックスドライバに更新することはできますか?
利用しているCPUなど、あなたの環境をもう少し詳しく書いていただけると、解決しやすいかもしれません。
アバター
kegare
ID:8c5f0b09
レッドスト―ン掘り
 
記事: 677
登録日時: 2012年10月27日(土) 06:06

  • (PostNo.275527)

Re: Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by yuta0381 » 2016年6月18日(土) 22:16

こちらに詳しく書かれていますもう一度、一からやってみては。
http://www.watermelonheadman.com/mc172-modding-1/
yuta0381
ID:1ca90264
大工さん
 
記事: 67
登録日時: 2016年6月18日(土) 22:01

  • (PostNo.275546)

Re: Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by sohui » 2016年6月18日(土) 23:48

yuta0381 さんが書きました:こちらに詳しく書かれていますもう一度、一からやってみては。
http://www.watermelonheadman.com/mc172-modding-1/

set JAVA_HOME=C:\PROGRA~1\Java\jdk1.8.0_77を追加したことと、ファイル場所と、バージョン以外は書いてある通りにやりましたが、多分同じエラーが出ました。
コンソール
[23:27:35] [main/INFO] [GradleStart]: username: sohui_syounaka
[23:27:35] [main/INFO] [GradleStart]: Extra: []
[23:27:35] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/  /.gradle/caches/minecraft/assets, --assetIndex, 1.7.10, --accessToken, {REDACTED}, --version, 1.7.10, --username, sohui_syounaka, --tweakClass, cpw.mods.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker]
[23:27:35] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[23:27:35] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[23:27:35] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
[23:27:35] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
[23:27:36] [main/INFO] [FML]: Forge Mod Loader version 7.99.36.1558 for Minecraft 1.7.10 loading
[23:27:36] [main/INFO] [FML]: Java is Java HotSpot(TM) Client VM, version 1.8.0_74, running on Windows 10:x86:10.0, installed at C:\pleiades\java\8\jre
[23:27:36] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
[23:27:36] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
[23:27:36] [main/INFO] [GradleStart]: Injecting location in coremod cpw.mods.fml.relauncher.FMLCorePlugin
[23:27:36] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
[23:27:36] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[23:27:36] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
[23:27:36] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[23:27:36] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[23:27:36] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[23:27:36] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[23:27:36] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!
[23:27:38] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
[23:27:38] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[23:27:38] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
[23:27:39] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[23:27:39] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.TerminalTweaker
[23:27:39] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.TerminalTweaker
[23:27:39] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[23:27:40] [main/INFO]: Setting user: sohui_syounaka
[23:27:42] [Client thread/INFO]: LWJGL Version: 2.9.1
[23:27:43] [Client thread/ERROR]: Couldn't set pixel format
org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method) ~[lwjgl-2.9.1.jar:?]
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52) ~[lwjgl-2.9.1.jar:?]
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252) ~[lwjgl-2.9.1.jar:?]
at org.lwjgl.opengl.Display.createWindow(Display.java:306) ~[lwjgl-2.9.1.jar:?]
at org.lwjgl.opengl.Display.create(Display.java:848) ~[lwjgl-2.9.1.jar:?]
at org.lwjgl.opengl.Display.create(Display.java:757) ~[lwjgl-2.9.1.jar:?]
at net.minecraftforge.client.ForgeHooksClient.createDisplay(ForgeHooksClient.java:327) ~[ForgeHooksClient.class:?]
at net.minecraft.client.Minecraft.startGame(Minecraft.java:474) [Minecraft.class:?]
at net.minecraft.client.Minecraft.run(Minecraft.java:942) [Minecraft.class:?]
at net.minecraft.client.main.Main.main(Main.java:164) [Main.class:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_74]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_74]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_74]
at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_74]
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source) [start/:?]
at GradleStart.main(Unknown Source) [start/:?]
[23:27:44] [Client thread/INFO] [STDOUT]: [net.minecraft.client.Minecraft:displayCrashReport:388]: ---- Minecraft Crash Report ----
// Would you like a cupcake?

Time: 16/06/18 23:27
Description: Initializing game

org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Display.create(Display.java:739)
at net.minecraft.client.Minecraft.startGame(Minecraft.java:494)
at net.minecraft.client.Minecraft.run(Minecraft.java:942)
at net.minecraft.client.main.Main.main(Main.java:164)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source)
at GradleStart.main(Unknown Source)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Display.create(Display.java:739)
at net.minecraft.client.Minecraft.startGame(Minecraft.java:494)

-- Initialization --
Details:
Stacktrace:
at net.minecraft.client.Minecraft.run(Minecraft.java:942)
at net.minecraft.client.main.Main.main(Main.java:164)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source)
at GradleStart.main(Unknown Source)

-- System Details --
Details:
Minecraft Version: 1.7.10
Operating System: Windows 10 (x86) version 10.0
Java Version: 1.8.0_74, Oracle Corporation
Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
Memory: 862733368 bytes (822 MB) / 1037959168 bytes (989 MB) up to 1037959168 bytes (989 MB)
JVM Flags: 4 total; -Xms1G -Xmx1G -XX:MetaspaceSize=512M -XX:MaxMetaspaceSize=512M
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML:
Launched Version: 1.7.10
LWJGL: 2.9.1
OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
GL Caps:
Is Modded: Definitely; Client brand changed to 'fml,forge'
Type: Client (map_client.txt)
Resource Packs: []
Current Language: ~~ERROR~~ NullPointerException: null
Profiler Position: N/A (disabled)
Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Anisotropic Filtering: Off (1)
[23:27:44] [Client thread/INFO] [STDOUT]: [net.minecraft.client.Minecraft:displayCrashReport:398]: #@!@# Game crashed! Crash report saved to: #@!@# C:\pleiades\workspace\forge-1.7.10-10.13.4.1558-1.7.10-src\eclipse\.\crash-reports\crash-2016-06-18_23.27.44-client.txt

kegare さんが書きました:Intel(R) HD Graphics 9.17.10.2828 は、Windows 8に対応するグラフィックスドライバのようですが、
"Windows 10に対応する"最新のグラフィックスドライバに更新することはできますか?

Intelの公式サイトから落としたものは、メーカーPCだからか更新できませんでした。(今はページがメンテ中のようで入れませんでした)
デバイスマネージャーから自動の更新を選んで実行したところバージョンが9.17.10.4229になりました。
kegare さんが書きました:利用しているCPUなど、あなたの環境をもう少し詳しく書いていただけると、解決しやすいかもしれません。

すいません、もっと詳しく、
CPU : Intel(R) Celeron(R) CPU B815 (スペック不足ですが今回の件には関係ないと思っているのですがどうでしょうか)
システム モデル : Aspire 5349
メモリ : 2048MB
これで大丈夫でしょうか?どんな情報を載せればいいのか分からなくて、
1.7.10もそろそろ古いのかなぁ
sohui
ID:627e7481
木を殴ってる
 
記事: 14
登録日時: 2014年11月01日(土) 15:28
お住まい: Solid State Drive

  • (PostNo.275550)

Re: Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by elise_blacklab » 2016年6月19日(日) 00:17

sohui さんが書きました:すいません、もっと詳しく、
CPU : Intel(R) Celeron(R) CPU B815 (スペック不足ですが今回の件には関係ないと思っているのですがどうでしょうか)
システム モデル : Aspire 5349
メモリ : 2048MB
これで大丈夫でしょうか?どんな情報を載せればいいのか分からなくて、

Celeron B815はSandy Bridge世代の番号なしIntel HD Graphicsに相当するものですが,おそらくスペック不足のためデバッグ用起動ができないのでしょう.(何故かは知りませんが,デバッグ用Launchのグラフィックス認識は通常のものより高いものが要求されるようです)
実際にモバイルマシンでデバッグを試行した体感では,同世代でもHD 3000,製品版におけるテストを含めた安定動作にはIvy Bridge以降のHD 4000が必要とされる印象です.
メイドつくってたりします.http://el-blacklab.net/
アバター
elise_blacklab
ID:3eae4f56
掘り廃人
 
記事: 2407
登録日時: 2014年6月25日(水) 18:30

  • (PostNo.275556)

Re: Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by sohui » 2016年6月19日(日) 01:27

elise_blacklab さんが書きました:Celeron B815はSandy Bridge世代の番号なしIntel HD Graphicsに相当するものですが,おそらくスペック不足のためデバッグ用起動ができないのでしょう.(何故かは知りませんが,デバッグ用Launchのグラフィックス認識は通常のものより高いものが要求されるようです)
実際にモバイルマシンでデバッグを試行した体感では,同世代でもHD 3000,製品版におけるテストを含めた安定動作にはIvy Bridge以降のHD 4000が必要とされる印象です.

返信ありがとうございます。
そうですか、残念です。前にmod開発を行いたいなと思ってデバッグしたときはできていたのですが(そのデータはHDDとともにお亡くなりになられましたが)、時間がたつとPCも消耗されていくということですね。
1.7.10もそろそろ古いのかなぁ
sohui
ID:627e7481
木を殴ってる
 
記事: 14
登録日時: 2014年11月01日(土) 15:28
お住まい: Solid State Drive

  • (PostNo.275562)

Re: Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by yuta0381 » 2016年6月19日(日) 02:45

sohui さんが書きました:
yuta0381 さんが書きました:こちらに詳しく書かれていますもう一度、一からやってみては。
http://www.watermelonheadman.com/mc172-modding-1/

set JAVA_HOME=C:\PROGRA~1\Java\jdk1.8.0_77を追加したことと、ファイル場所と、バージョン以外は書いてある通りにやりましたが、多分同じエラーが出ました。

パスはjdkの中にbinですよ。
\Java\jdk1.8.0_91\bin
それからコマンドプロンプトを開いて
”javac”を打って
'javac' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。
がでれば環境変数の設定が間違ってます。
yuta0381
ID:1ca90264
大工さん
 
記事: 67
登録日時: 2016年6月18日(土) 22:01

  • (PostNo.275579)

Re: Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by sohui » 2016年6月19日(日) 11:21

yuta0381 さんが書きました:パスはjdkの中にbinですよ。
\Java\jdk1.8.0_91\bin
それからコマンドプロンプトを開いて
”javac”を打って
'javac' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。
がでれば環境変数の設定が間違ってます。

返信ありがとうございます。
私の環境だけなのかもしれませんが、\binを追加すると
ERROR: JAVA_HOME is set to an invalid directory: C:\PROGRA~1\Java\jdk1.8.0_77\bin

Please set the JAVA_HOME variable in your environment to match the
location of your Java installation.
と表示され、セットアップできていないようです。

環境変数に追加されていたので"javac"の方は問題ないです。
1.7.10もそろそろ古いのかなぁ
sohui
ID:627e7481
木を殴ってる
 
記事: 14
登録日時: 2014年11月01日(土) 15:28
お住まい: Solid State Drive

  • (PostNo.275590)

Re: Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by yuta0381 » 2016年6月19日(日) 12:35

javaとjdkのアップデートをしてみてください
yuta0381
ID:1ca90264
大工さん
 
記事: 67
登録日時: 2016年6月18日(土) 22:01

  • (PostNo.275594)

Re: Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by elise_blacklab » 2016年6月19日(日) 13:32

yuta0381 さんが書きました:パスはjdkの中にbinですよ。

JAVA_HOMEに指定するのはbinではなくJDKのルートパスです.バージョン変えようが変わりません.
メイドつくってたりします.http://el-blacklab.net/
アバター
elise_blacklab
ID:3eae4f56
掘り廃人
 
記事: 2407
登録日時: 2014年6月25日(水) 18:30

  • (PostNo.284241)

Re: Forgeのmod開発環境を構築できない [1.7.10]

投稿記事by yuta0381 » 2016年9月27日(火) 23:35

elise_blacklab さんが書きました:
yuta0381 さんが書きました:パスはjdkの中にbinですよ。

JAVA_HOMEに指定するのはbinではなくJDKのルートパスです.バージョン変えようが変わりません.

完全に間違っていました
解答ありがとうございました!
yuta0381
ID:1ca90264
大工さん
 
記事: 67
登録日時: 2016年6月18日(土) 22:01


Return to 質問:開発・制作関連

cron

x