modのテストプレイができない

Modding・サーバPlugin制作・ツール制作など、開発関連の質問があればこちらにお願い致します。
フォーラムルール
質問関連フォーラムで質問する時は、必ず次のトピックを一読/厳守お願い致します。
viewtopic.php?f=5&t=999
  • (PostNo.294918)

modのテストプレイができない

投稿記事by micto » 2017年2月03日(金) 21:27

mod製作をしようと思い以下の動画の通りにやったのですがテストプレイ時にエラーが出ます。
開発環境構築
https://www.youtube.com/watch?v=0ibDQnI5_b4
下の動画04:17のところで実行Clientというボタンをこちらで押すとクラッシュレポートがでて起動できません。(コードは合っています)
https://www.youtube.com/watch?v=UJ7iOEkuBF8

環境
マインクラフトversion:1.10
forge version:12.18.0.2000
IDE:eclipse
os:windows10

クラッシュレポート
---- Minecraft Crash Report ----
// But it works on my machine.

Time: 17/02/03 18:10
Description: Initializing game

org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:247)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Display.create(Display.java:739)
at net.minecraft.client.Minecraft.createDisplay(Minecraft.java:634)
at net.minecraft.client.Minecraft.startGame(Minecraft.java:468)
at net.minecraft.client.Minecraft.run(Minecraft.java:386)
at net.minecraft.client.main.Main.main(Main.java:118)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)
at GradleStart.main(GradleStart.java:26)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Thread: Client thread
Stacktrace:
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:247)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Display.create(Display.java:739)
at net.minecraft.client.Minecraft.createDisplay(Minecraft.java:634)
at net.minecraft.client.Minecraft.startGame(Minecraft.java:468)

-- Initialization --
Details:
Stacktrace:
at net.minecraft.client.Minecraft.run(Minecraft.java:386)
at net.minecraft.client.main.Main.main(Main.java:118)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)
at GradleStart.main(GradleStart.java:26)

-- System Details --
Details:
Minecraft Version: 1.10
Operating System: Windows 10 (amd64) version 10.0
Java Version: 1.8.0_121, Oracle Corporation
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 750552952 bytes (715 MB) / 1037959168 bytes (989 MB) up to 1037959168 bytes (989 MB)
JVM Flags: 3 total; -Xincgc -Xmx1024M -Xms1024M
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML:
Loaded coremods (and transformers):
Launched Version: 1.10
LWJGL: 2.9.4
OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
GL Caps:
Using VBOs: Yes
Is Modded: Definitely; Client brand changed to 'fml,forge'
Type: Client (map_client.txt)
Resource Packs:
Current Language: ~~ERROR~~ NullPointerException: null
Profiler Position: N/A (disabled)
CPU: <unknown>

以下のトピックを参考にクラッシュレポートの解析をしたところ、pcに問題があるそうでした。
http://forum.minecraftuser.jp/viewtopic.php?t=7032
しかし普通に(ランチャーから)起動しても何事もなく起動します(バニラ・forgeありでも)
どなたか解決方法を教えてください、お願いします。
建築は大の苦手です
mod製作をがんばっています
micto
ID:1fffeb19
水から上がったとこ
 
記事: 4
登録日時: 2017年1月15日(日) 00:05

  • (PostNo.294927)

Re: modのテストプレイができない

投稿記事by elise_blacklab » 2017年2月03日(金) 22:24

通常の環境では起動できるけどeclipseからの開発環境からは起動できないというケースは有り得ない話ではないです.現に私が前使っていたノート機ではそうでしたし.
早い話が"製品版が起動するギリギリくらいのスペック"ということは考えられます.一応詳細なスペック(もちろんCPUやメモリ,グラボ等,メーカー品なら型番も)を記載してみてください.
メイドつくってたりします.http://el-blacklab.net/
アバター
elise_blacklab
ID:f6eae7d1
掘り廃人
 
記事: 2381
登録日時: 2014年6月25日(水) 18:30

  • (PostNo.295002)

Re: modのテストプレイができない

投稿記事by micto » 2017年2月04日(土) 19:21

製造元:Dell
モデル:Optiplex 7010
プロセッサ:Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz 3.40GHz
実装メモリ:8.00GB
システムの種類:64ビット オペレーティング システム、x64 ベース プロセッサ
グラフィックボード:Intel(R) HD Graphics Family
建築は大の苦手です
mod製作をがんばっています
micto
ID:1fffeb19
水から上がったとこ
 
記事: 4
登録日時: 2017年1月15日(日) 00:05

  • (PostNo.295031)

Re: modのテストプレイができない

投稿記事by CrafterKina » 2017年2月05日(日) 04:14

Windows10かつ1,2世代のIntel HD graphics chipsetsでMinecraftを動かす場合、8u60より前のJREで起動しないとクラッシュしてしまいます。
お使いのPCのプロセッサがi7-2600とのことですのでこれが原因だと思われます。
8u60より前のJREはMinecraftのインストール時に付属してきますので、そのJREから起動するように起動構成を設定すると直るはずです。
(一応、ここから8u51が落とせますが、Minecraftの起動でしか使いませんので付属のものを使ったほうが簡便です。)
当方Eclipseを使っておりませんのでこれ以上詳細な説明はできませんが、確認してみてください。
公式情報貼っときます。
http://hopper.minecraft.net/help/pixel-format-not-accelerated/
アバター
CrafterKina
ID:10ad58cf
石炭掘り
 
記事: 190
登録日時: 2013年4月06日(土) 14:42
お住まい: 廃坑

  • (PostNo.295135)

Re: modのテストプレイができない

投稿記事by micto » 2017年2月05日(日) 22:47

CrafterKina さんが書きました:8u60より前のJREはMinecraftのインストール時に付属してきますので、そのJREから起動するように起動構成を設定すると直るはずです。

起動構成の設定方法がよくわかりません。もしよかったら教えてください。
建築は大の苦手です
mod製作をがんばっています
micto
ID:1fffeb19
水から上がったとこ
 
記事: 4
登録日時: 2017年1月15日(日) 00:05

  • (PostNo.295139)

Re: modのテストプレイができない

投稿記事by elise_blacklab » 2017年2月06日(月) 00:04

micto さんが書きました:起動構成の設定方法がよくわかりません。もしよかったら教えてください。

その辺はeclipseの使い方になるので、ご自分でお調べになるか余所で質問してください。
メイドつくってたりします.http://el-blacklab.net/
アバター
elise_blacklab
ID:defac7af
掘り廃人
 
記事: 2381
登録日時: 2014年6月25日(水) 18:30

  • (PostNo.295160)

Re: modのテストプレイができない

投稿記事by micto » 2017年2月06日(月) 17:46

ありがとうございます
建築は大の苦手です
mod製作をがんばっています
micto
ID:1fffeb19
水から上がったとこ
 
記事: 4
登録日時: 2017年1月15日(日) 00:05


Return to 質問:開発・制作関連

x