[解決済み]Limitsというプラグインを1.12に移植する方法について

Modding・サーバPlugin制作・ツール制作など、開発関連の質問があればこちらにお願い致します。
フォーラムルール
質問関連フォーラムで質問する時は、必ず次のトピックを一読/厳守お願い致します。
viewtopic.php?f=5&t=999
  • (PostNo.305885)

[解決済み]Limitsというプラグインを1.12に移植する方法について

投稿記事by みずきち » 2017年8月06日(日) 16:10

こんにちは。

現在、Limits(https://www.spigotmc.org/resources/limits.29791/)というプラグインを1.12用に移植しています。(対応が1.10シリーズまで)

なのですが、worldedit等の物をimportするあたりで行き詰まってしまいました。

コード: 全て選択
import com.sk89q.worldedit.BlockVector;
など

そもそも移植の方法がおかしいのかもしれませんが...

一通り探したりしてみましたが方法を見つけることはできませんでした。

知っている方がいれば、誰か教えていただきたいです。

よろしくお願いします。
最後に編集したユーザー みずきち [ 2017年8月07日(月) 11:15 ], 累計 1 回
みずきち
ID:c276afed
木を殴ってる
 
記事: 19
登録日時: 2015年11月16日(月) 15:40

  • (PostNo.305888)

Re: Limitsというプラグインを1.12に移植する方法について

投稿記事by みずきち » 2017年8月06日(日) 16:42

申し訳ありません。
環境を書くのを忘れていました。
Eclipse 4.6 NEONを使用しています。
みずきち
ID:c276afed
木を殴ってる
 
記事: 19
登録日時: 2015年11月16日(月) 15:40

  • (PostNo.305892)

Re: Limitsというプラグインを1.12に移植する方法について

投稿記事by Lemon18 » 2017年8月06日(日) 17:57

みずきち さんが書きました:現在、Limits(https://www.spigotmc.org/resources/limits.29791/)というプラグインを1.12用に移植しています。(対応が1.10シリーズまで)

なのですが、worldedit等の物をimportするあたりで行き詰まってしまいました。


WorldEdit本体をビルドパスに追加すればいいかと。
Bukkitプラグインとか作ったり作らなかったり。
「どのOSでも使える」を目標に日本語入力ツールを作っています。良ければ見てください。
http://forum.minecraftuser.jp/viewtopic.php?f=36&t=31671


Twitter: https://twitter.com/Lemon1806
Minecraft: Applemon
Lemon18
ID:cb27c883
石掘り
 
記事: 85
登録日時: 2015年6月05日(金) 22:42

  • (PostNo.305925)

Re: Limitsというプラグインを1.12に移植する方法について

投稿記事by みずきち » 2017年8月07日(月) 11:15

ありがとうございます!解決しました!
みずきち
ID:c276afed
木を殴ってる
 
記事: 19
登録日時: 2015年11月16日(月) 15:40


Return to 質問:開発・制作関連

x