MinecraftAPIについて

テクスチャやMODの導入に関する質問はこちらでどうぞ!
フォーラムルール
質問関連フォーラムで質問する時は、必ず次のトピックを一読/厳守お願い致します。
viewtopic.php?f=5&t=999
  • (PostNo.309786)

MinecraftAPIについて

投稿記事by 125player » 2017年11月01日(水) 05:24

質問です。
1.2.5でMODを導入して遊んでいるのですが、
SayoさんのMODを導入するために、MinecraftAPI(以下、MCAPI)っていうのが前提MODになっています。
で、今のMCAPIのバージョンが1.19.161123なのですが、それより新しいバージョンをMCPatcherで導入すると
Minecraftが開かなくなります。
どうすればいいですか?

Windows10
java 1.8.0_25
LWJGL 2.9.0
Minecraft 1.2.5
Forge 3.4.9.171
125player
ID:da05adc8
 

  • (PostNo.309899)

Re: MinecraftAPIについて

投稿記事by cooky_0323 » 2017年11月04日(土) 10:29

MCAPI 1.21.170427なら動かすことが可能です。

※バックアップを必ず取ってください
※自己責任でお願いします。

まず、MCAPI 1.19.170122MCAPI 1.21.170427をダウンロードします。
この二つをデスクトップなりにフォルダを作ってそこに分けて保存してください。

次に7zipなりをダウンロードします。
ダウンロードしたら、7zipで先ほど保存したMCAPI 1.19MCAPI 1.21を開いてください。

開いたら、MCAPI 1.21の中のファイル
cpw\mods\fml\client\FMLClientHandler.class
net\minecraft\client\Minecraft.class

MCAPI 1.19の中にあるファイル
cpw\mods\fml\client\FMLClientHandler.class
net\minecraft\client\Minecraft.class
それぞれ置き換えます。

それ以外は弄らないでください。

MCAPI 最新版は今のところこの方法で動かないので、私が対策方法を考えています。

見つけ次第、私のTwitterで報告しますので、最新版で起動したいのであればもう少し待ってくださいね。

~補足~
旧ランチャーが使える環境なのであれば、旧ランチャーを使用してください。

また、LWJGLが2.9.0なので更新して2.9.3にすればこの方法を取らなくても起動するかもしれません。

~補足2~
JavaのVersionもどうやら古いようなので、更新するのをおすすめします。

1.2.5はJava7でも動くので、MCAPIにJava8で削除されたコードが入ってたら起動しないので、Java7にするともしかしたら起動するかもしれません。
アバター
cooky_0323
ID:4810340c
大工さん
 
記事: 47
登録日時: 2016年11月12日(土) 22:53
お住まい: 日本

  • (PostNo.309900)

Re: MinecraftAPIについて

投稿記事by cooky_0323 » 2017年11月04日(土) 11:19

cooky_0323 さんが書きました:


最新版で動かす方法を発見しました。
この作業もバックアップを必ず取ってください。また、自己責任でお願いします。

まず、MCAPI-1.19.170122MCAPI-1.21.170427MCAPI-1.22.827をダウンロードします。
このファイルをデスクトップなりにフォルダ作って分けて保存しておいてください。

MCAPI 1.22MCAPI 1.21MCAPI 1.19を7zipで開きます。

MCAPI 1.22内のフォルダ
minecraftAPI\mod_MinecraftAPI.class
minecraftAPI\mod_MinecraftAPI$1.class

MCAPI 1.21内のフォルダ
minecraftAPI\mod_MinecraftAPI.class
minecraftAPI\mod_MinecraftAPI$1.classにそれぞれ置き換えます。

MCAPI 1.22内のフォルダ
cpw\mods\fml\client\FMLClientHandler.class
net\minecraft\client\Minecraft.class

MCAPI 1.19内のフォルダ
cpw\mods\fml\client\FMLClientHandler.class
net\minecraft\client\Minecraft.classにそれぞれ置き換えます。

これで、置き換えたMCAPI 1.22をjar導入ソフトmcpatcherで
Forge→Optifine C7→TMI→SPC→他jar導入系mod→MCAPI
の順にしたらMagicLauncherなどで起動するかと思います。

新ランチャーはおすすめしません。MagicLauncherをおすすめします。

また、LWJGLとJavaも早めに更新することをおすすめします。
アバター
cooky_0323
ID:4810340c
大工さん
 
記事: 47
登録日時: 2016年11月12日(土) 22:53
お住まい: 日本

  • (PostNo.310099)

Re: MinecraftAPIについて(解決済み)

投稿記事by 125player » 2017年11月08日(水) 17:02

ありがとうございます。
おかげでMCAPIの導入に成功しました。
一応、新ランチャーでも起動できました。
本当にありがとうございました。
125player
ID:da05adc8
 


Return to 質問:MOD/テクスチャ/その他ツール関係

x