DQM forge1.5.2導入について

テクスチャやMODの導入に関する質問はこちらでどうぞ!
フォーラムルール
質問関連フォーラムで質問する時は、必ず次のトピックを一読/厳守お願い致します。
viewtopic.php?f=5&t=999
  • (PostNo.311510)

DQM forge1.5.2導入について

投稿記事by mssp » 2017年12月18日(月) 03:43

好きな動画投稿グループがDQMを導入してて、面白そうなので自分もやりたいと思い、数時間格闘しましたw
正直、調べられるところまで調べて限界を感じたので皆さん助けてw

forge1.5.2を起動させるときに、以下のエラーが出ます。
-- System Details --
Details:
Minecraft Version: 1.5.2
Operating System: Windows 10 (amd64) version 10.0
Java Version: 1.7.0_80, Oracle Corporation
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 143033288 bytes (136 MB) / 268435456 bytes (256 MB) up to 1073741824 bytes (1024 MB)
JVM Flags: 8 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=16M
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Suspicious classes: FML and Forge are installed
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML:
LWJGL: 2.9.0
OpenGL: Intel(R) HD Graphics 5500 GL version 4.4.0 - Build 20.19.15.4531, Intel
Is Modded: Definitely; Client brand changed to 'fml,forge'
Type: Client (map_client.txt)
Texture Pack: Default
Profiler Position: N/A (disabled)
Vec3 Pool Size: ~~ERROR~~ NullPointerException: null

java.lang.RuntimeException
at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:140)
at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:411)
at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)
at net.minecraft.client.Minecraft.run(Minecraft.java:733)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT 6ea72d64 ----------

Vec3 pool Sizeと一番下のところでエラーが出てて、調べ手は見たのですがわかりませんでした。
mssp
ID:756a5998
 

  • (PostNo.311512)

Re: DQM forge1.5.2導入について

投稿記事by Slipstream » 2017年12月18日(月) 07:38

原因を突き止めるため、導入しているModのファイル名を全部書くこと、Forgeのバージョンを書くこと、それからJavaやWindowsなど実行環境を書くことが必要です。
【必読】質問の仕方について(viewtopic.php?f=5&t=999)も併せてお読みください。
Androidのアプリ作ってる人
Minecraft1.7.10で現代建築やってます
たまにはフォーラムにも顔を出します
質問に答えるときは投稿日をちゃんと見よう、1カ月以上前の質問は無視しよう
ちゃんとルールにのっとった質問にしか回答は書きません
ルールに従って質問修正してくれたらちゃんと答えます

And he was never seen again...
Slipstream
ID:d389cd18
石炭掘り
 
記事: 218
登録日時: 2014年3月11日(火) 23:52
お住まい: 博多市(福岡市)

  • (PostNo.311513)

Re: DQM forge1.5.2導入について

投稿記事by ゲスト » 2017年12月18日(月) 09:00

ご指摘ありがとうございます。
modはforge導入前なので何も入れておらず、そもそもmodファイルすら作成されていない状況です。
また、以前使っていたmodは競合のエラーが出たらめんどくさいと思ったので、全て削除しました。

forge、java、osについては、題にforge1.5.2、エラーのシステム詳細にjava1.7.0_80、oswin10と表記されていたので、省いてしまいました。
forge1.5.2の導入失敗例が多く、jsonファイルの書き換え、optionファイルの削除、javaのダウングレードと言った、細かい部分まで試してはみました…
また、forgeで起動しないときはver関係なく、普通にプレイできる状況です。
forge1.5.2以外で開けるかを確認したいと思ったところで昨日は断念してしましました。

アインストールは何度も繰り返しているので、これら以外の試すべき方法はありますか?
ゲスト
ID:1432e740
 

  • (PostNo.311515)

Re: DQM forge1.5.2導入について

投稿記事by Slipstream » 2017年12月18日(月) 09:29

状況がおおよそ掴めました。
Mod導入数0で、Java7 Update80、Windows7という環境ですね。
一応、ルール上はクラッシュレポートとたとえ重複している内容でも、最低限書いてもらうことになっています。
質問する側にとっても、現在の状況を整理するという意味では、多少手間がかかってもしっかり書いた方が、むしろ問題解決の近道になる場合すらあります。

それから、Forge1.5.2という書き方では、バージョン名をうまく書けているとは言えません。

Minecraft Forgeには、Forge1.12.2 - 14.23.1.2577というように、細かいバージョンやビルド番号がついています。
たとえば上記のForge1.12.2 - 14.23.1.2577の場合、Minecraftのバージョンが「1.12.2」、Forgeのバージョンが「14.23.1」、ビルド番号が「2577」となります。

基本的には、Forgeのバージョンを聞かれた際には、Forgeのバージョンとビルド番号が両方とも必要になります。
先程例に書いたように、「Forge1.12.2 - 14.23.1.2577」という風に書くのがおすすめの書き方です。

また、この方法は推奨できませんが、一応ビルド番号だけを書いても(例.Forge1.12.2#2577)通じることがあります。環境やModのバージョンなどに一切記入漏れがない時に限り、基本的に指摘しないことが多いです。


今回の事例では、クラッシュレポートにしては珍しくForgeのバージョンが記載されていないので、調べて書いていただくしかありません。
Androidのアプリ作ってる人
Minecraft1.7.10で現代建築やってます
たまにはフォーラムにも顔を出します
質問に答えるときは投稿日をちゃんと見よう、1カ月以上前の質問は無視しよう
ちゃんとルールにのっとった質問にしか回答は書きません
ルールに従って質問修正してくれたらちゃんと答えます

And he was never seen again...
Slipstream
ID:d389cd18
石炭掘り
 
記事: 218
登録日時: 2014年3月11日(火) 23:52
お住まい: 博多市(福岡市)

  • (PostNo.311516)

Re: DQM forge1.5.2導入について

投稿記事by ゲスト » 2017年12月18日(月) 09:46

早速の回答ありがとうございます。
一応なのですが、osはwin10です。
10にしてから、不具合多くて嫌になってます笑

forgeについては、最新版の1.5.2_7.8.1.738をdlしました。
ゲスト
ID:1432e740
 

  • (PostNo.311519)

Re: DQM forge1.5.2導入について

投稿記事by Slipstream » 2017年12月18日(月) 10:11

ゲスト さんが書きました:一応なのですが、osはwin10です。

失礼しました、私の誤字です。本当に申し訳ない...。
Windows10だということはちゃんと伝わっていたのでご心配なく。

Forgeのバージョンに問題がないことが確認できました。

対処法なのですが、おそらく次のような手順で直るのではないかなと思います。一通り試してみてください。

1_「.Minecraft」フォルダの「Versions」の中身を一旦消す。
(1.5.2以外にModを導入しているプロファイルが無ければOK。1.5.2以外でModを導入しているプロファイルがあれば、残しておいてください。)

2_バニラのMinecraft1.5.2を起動する。

3_7-zipを使い、Forge1.5.2-7.8.1.738のUniversal版をインストール。jsonファイルの書き換えも忘れずに。
(参考URL:http://forum.minecraftuser.jp/viewtopic.php?t=30111&p=262024#p262024)
※7-zipのインストールや使用方法などはお調べください。

4_Forgeの入ったプロファイルを起動。

5_エラーが出るはずなので、必要なファイルをlibフォルダに入れる。
(参考URL:http://forum.minecraftuser.jp/viewtopic.php?f=6&t=15745)

6_無事起動すればForgeのインストールは完了。

もし起動しない場合は、1番からやり直しです。

この方法で無事にForgeがインストールできたら、DQMを導入できるか試してください。
Androidのアプリ作ってる人
Minecraft1.7.10で現代建築やってます
たまにはフォーラムにも顔を出します
質問に答えるときは投稿日をちゃんと見よう、1カ月以上前の質問は無視しよう
ちゃんとルールにのっとった質問にしか回答は書きません
ルールに従って質問修正してくれたらちゃんと答えます

And he was never seen again...
Slipstream
ID:d389cd18
石炭掘り
 
記事: 218
登録日時: 2014年3月11日(火) 23:52
お住まい: 博多市(福岡市)

  • (PostNo.311521)

Re: DQM forge1.5.2導入について

投稿記事by ゲスト » 2017年12月18日(月) 12:42

回答ありがとうございます。

一応、その流れは何度も繰り返して、ファイルの削除も試してはみました。
それでも、forgeが起動しなかったんですね。
今日、もう一度ゆっくり最初からやってみるつもりではあるのですが、これでもダメな場合の対処法はあるのでしょうか?
ゲスト
ID:1432e740
 

  • (PostNo.311537)

Re: DQM forge1.5.2導入について

投稿記事by Slipstream » 2017年12月18日(月) 19:10

対処法というか、それ以前に原因が今のところ不明なのでそれを突き止めるのが先決という感じがありますね。

あくまでも先程の対処法は、Modの導入手順に問題があった場合などに使えるもので、それ以外に何か問題があった場合は、やはり依然として起動しないままですね...。

(一応確認ですが)Modを導入する時にminecraft.jarのMETA-INFを消し忘れているとか、削除したはずのMETA-INFが復活してしまうとか、そういった問題ではないんですよね。

こちらの環境(Windows7 64bit版、Java7 Update80 64bit版、Forgeは1.5.2-7.8.7.738)でも症状が再現されるか、一応テストしているのですが...。
私がプレイする際は非公式ランチャーを使っており、公式ランチャーを長い間使っていなかったため、恥ずかしながら「公式ランチャーの仕様変更に戸惑う」というマヌケな事態に直面しております。

しばらく時間がかかりそうなので、一応ご報告まで。
Androidのアプリ作ってる人
Minecraft1.7.10で現代建築やってます
たまにはフォーラムにも顔を出します
質問に答えるときは投稿日をちゃんと見よう、1カ月以上前の質問は無視しよう
ちゃんとルールにのっとった質問にしか回答は書きません
ルールに従って質問修正してくれたらちゃんと答えます

And he was never seen again...
Slipstream
ID:d389cd18
石炭掘り
 
記事: 218
登録日時: 2014年3月11日(火) 23:52
お住まい: 博多市(福岡市)

  • (PostNo.311542)

Re: DQM forge1.5.2導入について

投稿記事by Slipstream » 2017年12月18日(月) 20:27

ご報告です。
上記の私の環境で、DQMIVの導入に成功しました。
ランチャーはWindows版ランチャー2.0を使用しています。

jsonファイルについてですが、自分で作っていては書式が崩れたりして割に合わないということで、下記の動画の説明欄より完成品を拾ってきましょう。
https://www.youtube.com/watch?v=V_sC6N2cF84

導入方法も上記動画の解説の通りで良いようです。

最初に上げていただいたような、「java.lang.RuntimeException」のエラーは再現されませんでした。
ただし、私の環境では、jsonファイルのミス次第では「java.lang.NoSuchFieldException」というエラーを吐きだし、前提Modを読み込まずに本体を先に読み込んだ場合は、ランチャーログに「java.lang.NoClassDefFoundError: Lnet/minecraft/entity/player/DQMEntityPlayerSP;」というエラーが出てくることを確認しました。

お手数をおかけした挙句他力本願の回答になってしまうという失態...。


もしこれでも導入できない場合は、また質問をください。
Androidのアプリ作ってる人
Minecraft1.7.10で現代建築やってます
たまにはフォーラムにも顔を出します
質問に答えるときは投稿日をちゃんと見よう、1カ月以上前の質問は無視しよう
ちゃんとルールにのっとった質問にしか回答は書きません
ルールに従って質問修正してくれたらちゃんと答えます

And he was never seen again...
Slipstream
ID:d389cd18
石炭掘り
 
記事: 218
登録日時: 2014年3月11日(火) 23:52
お住まい: 博多市(福岡市)

  • (PostNo.311554)

Re: DQM forge1.5.2導入について

投稿記事by ゲスト » 2017年12月19日(火) 00:28

回答ありがとうございます。

私も、
https://www.youtube.com/watch?v=V_sC6N2cF84
同じ動画を参照して、これに従い、jsonファイル等も拾ってきました。
また、7-zipで開いた際に、META-INFの消し忘れ、復活はしていないことは確認しました。

私も、そもそもforgeが動かない状況なのかと思い、forge1.7.10と1.10.2で試してみましたが、java8とjava7どちらでも動作することが確認できました。
つまり、javaが問題なのではなく、forge1.5.2がどうもうまく動いてないと思い、javaとの相性が悪いのかなと思ったため、(他の人は同じverで動いてたため可能性は低いのですが)java7の最新版じゃない方でも試してみたのですが、動作しませんでした...

前提modつまりforgeを入れる前に、modsファイルに何も入れてないので、modを先に読み込むということはないと思うんですね。

色々回答いただいたのですが、正直諦めかけてた時、1.7.10のDQMがあると聞き、それをdlしてプレイできたため、やった!と思っていたら、ver1.5.2とは違ったため、なんかやる気が起きず、結局諦めきれずにいましたw

でも、実際に成功例があるやり方でしかやっていないのに、エラーが起こり、海外wikiでも私と全く同じという人はいたのですが、回答どうりにもやってもだめなため、これはもうだめなんですかねw
ゲスト
ID:756a5998
 

  • (PostNo.311555)

Re: DQM forge1.5.2導入について

投稿記事by Slipstream » 2017年12月19日(火) 01:14

ゲスト さんが書きました:
回答ありがとうございます。

私も、
https://www.youtube.com/watch?v=V_sC6N2cF84
同じ動画を参照して、これに従い、jsonファイル等も拾ってきました。
また、7-zipで開いた際に、META-INFの消し忘れ、復活はしていないことは確認しました。

私も、そもそもforgeが動かない状況なのかと思い、forge1.7.10と1.10.2で試してみましたが、java8とjava7どちらでも動作することが確認できました。
つまり、javaが問題なのではなく、forge1.5.2がどうもうまく動いてないと思い、javaとの相性が悪いのかなと思ったため、(他の人は同じverで動いてたため可能性は低いのですが)java7の最新版じゃない方でも試してみたのですが、動作しませんでした...

前提modつまりforgeを入れる前に、modsファイルに何も入れてないので、modを先に読み込むということはないと思うんですね。

色々回答いただいたのですが、正直諦めかけてた時、1.7.10のDQMがあると聞き、それをdlしてプレイできたため、やった!と思っていたら、ver1.5.2とは違ったため、なんかやる気が起きず、結局諦めきれずにいましたw

でも、実際に成功例があるやり方でしかやっていないのに、エラーが起こり、海外wikiでも私と全く同じという人はいたのですが、回答どうりにもやってもだめなため、これはもうだめなんですかねw


うーん、そうですねぇ...。

本当に心苦しいですが、あなたの環境と同じような症状がこちらの環境で再現できなかったので、原因の追及がこれ以上困難です。
申し訳ございませんが、今回はお手上げということにさせてください。

もし他に何台かPCをお持ちであれば、環境を変えて動作するか試してみる価値はあるでしょう。
(実際に私も、Windows 10でMinecraftが正常に動かなかったためWindows7にダウングレードを試して、結果的に今もWindows7を使い続けていたりしますので...。)

それでは、この辺で。
Androidのアプリ作ってる人
Minecraft1.7.10で現代建築やってます
たまにはフォーラムにも顔を出します
質問に答えるときは投稿日をちゃんと見よう、1カ月以上前の質問は無視しよう
ちゃんとルールにのっとった質問にしか回答は書きません
ルールに従って質問修正してくれたらちゃんと答えます

And he was never seen again...
Slipstream
ID:d389cd18
石炭掘り
 
記事: 218
登録日時: 2014年3月11日(火) 23:52
お住まい: 博多市(福岡市)

  • (PostNo.311556)

Re: DQM forge1.5.2導入について

投稿記事by ゲスト » 2017年12月19日(火) 01:44

親身になって、原因解明に努めて頂きとても感謝していますm(_ _)m

ありがとうございました。
ゲスト
ID:756a5998
 


Return to 質問:MOD/テクスチャ/その他ツール関係

x