【よくある質問】MCPatcherでMODを導入できない

テクスチャやMODの導入に関する質問はこちらでどうぞ!
フォーラムルール
質問関連フォーラムで質問する時は、必ず次のトピックを一読/厳守お願い致します。
viewtopic.php?f=5&t=999
  • (PostNo.65955)

【よくある質問】MCPatcherでMODを導入できない

投稿記事by takanasayo » 2012年12月02日(日) 23:55

:ply: Q:MCPatcher HD Fixを使ってMODを導入すると失敗します。

:not: A:導入の手順や使い方が間違っています。
MCPatcher HD Fix はMODの導入を補助するソフトです。
Minecraft.jar のバックアップや導入MODの切り替え、META-INFの削除などを自動化するだけですので、MCPatcher HD Fix を使用したからといって Minecraft が起動しなくなることはありません。

起動しなくなった場合、様々な原因が考えられますので、下記の項目を確認してみてください。


:not: 同梱MODは競合していませんか?

同梱MODは他の同系MODと競合する事が多いため、最も原因となりやすいです。

例えば、MinecraftForge は HD Textures と競合します。
OptiFine は、ほぼ全ての同梱MODと競合し、起動不可もしくは誤動作を引き起こします。
同梱MODは必要なければ、全てチェックを外しておくと良いでしょう。

Tips: 同梱MODとは?
同梱MODとは、MCPatcher HD Fix起動時に、最初からリストに入っているMODです。
これらはリストから削除できないのですぐにわかります。
これらを外してもMCPatcher HD Fixの動作には影響ありません。

Tips: 起動時のエラーメッセージが出る場合
Minecraft.jarとバージョンが合わないMCPatcher HD Fixを使用している場合、MCPatcher HD Fix使用中に頻繁にエラーメッセージが出ます。
このメッセージを表示させたくない場合は、対応するバージョンのMCPatcher HD Fixを使いましょう。
ただし、バージョンの違うMCPatcher HD Fixを使っていても特に問題はありません。

Tips: バージョンの違うMCPatcher HD Fixを使った場合
MCPatcher HD Fixは、本体のバージョンがMinecraftと違ってもMODの導入には影響しません。
これは同梱MODも同じです。
同梱MODは通常のMODと異なり、複数のバージョンに適用できます。
適用できないバージョンであれば自動的に使用不可になり、逆に導入可能な場合であれば、上のバージョンのMinecraftであっても導入が可能です。
例えば1.4.5用のMCPatcher HD Fix同梱MODは、1.2.5でも使えます。
1.2.5用のMCPatcher HD Fix同梱MODの場合も、使用可能になっている2つは1.4.5にも導入可能です。


:not: 導入するMODのバージョンは合ってますか?

MODのバージョンとMinecraft.jarのバージョンは本当に合っているか確認してください。
MODは基本的にバージョンが合わなければ導入できません。
例えば、Minecraft.jarが製品版1.2.5なら、MODも全て1.2.5用でなければいけません。
これはmodsフォルダに入れるMODも含めて、全てのMODに共通する事なので注意しましょう。

Tips: ModLoader1.2.5で良くあるミス
ModLoader を 1.2.5 に導入する場合には ModLoader1.2.4 を使用します。
リストに 1.2.5 が無いため、誤って A1.2.5(alpha1.2.5用)を導入する人が多いですが、
alpha版はbeta版よりも更に前に公開されていた最も古いバージョンなので、当然互換性はありません。

Tips: 1.2.5や1.4.5対応MODがない場合
MODの中には、1.2.5や1.4.5対応のバージョンが抜けている場合があります。
これらのMODに1.2.4、1.4.4対応のものがあれば、それを使える可能性が高いです。
1.2.5には1.2.4のMOD、1.4.5には1.4.4のMODを試してみてください。
また、1.4.7には1.4.6のMODが使用できます。


:not: MODの導入方法は合ってますか?

MCPatcher HD Fixで導入できるのは、Minecraft.jarに上書きするタイプのMODだけです(例外もあるが)
その他の導入方法が必要なMODは、その手順に従ってください。
例えば影MODなどはMCPatcher HD Fixでは導入できません。

Tips: MCPatcher HD Fixで導入できるファイルの拡張子
MCPatcher HD Fixでは、zipファイルで配布されているMODしか導入できません。
導入方法が Minecraft.jarに上書きするタイプで、rar や jar で配布されているMODは、一度解凍してから zip で再圧縮する事により、導入可能になる場合があります。
その際、MODの jarファイルに META-INFフォルダがある場合は、削除して導入する必要があります。


:not: MODの導入順番は合っていますか?

MODは競合回避のために、導入順番が決められているものがあります。
例えば、MinecraftForge と Optifine は、Forge を先に入れなければいけません。

MCPatcher HD Fixでは、リストの上から順に導入されます。
リストの順番は、▲▼ボタンで変える事ができます。
MODの説明をよく読み、指定された順番に並べてください。


:not: 導入しようとしているMinecraft.jarは本当にバニラ状態ですか?

MCPatcher HD Fixはバニラ状態のMinecraft.jarを使う事を前提として作られています。
当然、バニラ状態ではないMinecraft.jarでは動作保障されていません。
必ずバニラ状態のMinecraft.jarを使用してください。

また、Minecraft.jarに上書きするタイプのMODは、既存のファイルを書き換えます。
そのため、ファイルの削除などでは元の状態に戻す事はできません。
必ずバニラ状態のバックアップから復元してください。

バニラ状態のバックアップがない場合は、バックアップしなかった自分の愚かさを呪いましょう。
Minecraft.jarを削除してマイクラを起動すれば、最新版なら自動的にダウンロードされます。
古いバージョンが欲しい?知らんがな。自分の愚かさを呪え。

Tips: バニラとは?
バニラ状態とは、MODが何も入っていない初期状態の事です。
前述のように、ファイルの削除ではバニラには戻りません。
「MODを抜いた」状態はバニラではなく、「MODを入れる前の状態に戻した」ものがバニラです。


:not: modsフォルダは空ですか?

MCPatcher HD Fixで前提MODを変えたり外したりした場合、modsフォルダに未対応のMODが入っていると起動しなくなります。
MODの導入を試す場合には、modsフォルダは空にしておきましょう。
特にバージョンアップの際に忘れやすいので、注意しましょう。

Tips: MODに関係するフォルダ
MODを導入すると、modsフォルダ以外にも様々なフォルダが作成されます。
環境をバニラに戻す場合には、これらのフォルダも全て削除した方がよいでしょう。
.minecraftフォルダ内に元々からあるフォルダは、bin、resource、saves、texturepacks の4つだけです。


:not: Minecraft.jarを間違えていませんか?

書き換えるMinecraft.jarは、.minecraft/bin/ にあるMinecraft.jarです。
.minecraft/ にあるMinecraft.jarを書き換えても意味がありません。
まさかとは思いますが、そんな事・・・あるわけないですよね?
最後に編集したユーザー takanasayo [ 2013年1月09日(水) 22:31 ], 累計 18 回
アバター
takanasayo
ID:c4f2ee5c
ラピスラズリ収集家
 
記事: 954
登録日時: 2012年7月26日(木) 04:00
お住まい: 石の中にいる

  • (PostNo.65956)

MCPatcherのTips

投稿記事by takanasayo » 2012年12月02日(日) 23:56

:ply: Q:別フォルダから起動可能にしたマイクラごとにMCPatcher HD Fixを使い分けたい。

:not: A:バッチファイルを作りましょう。

例えば、
M:/Minecraft1.2.5/.minecraft/ にマイクラ1.2.5を、
M:/Minecraft1.4.5/.minecraft/ にマイクラ1.4.5をインストールしているとします。

M:/Minecraft1.2.5/ に、1.2.5用のMCPatcher HD Fix(mcpatcher-2.3.5_01.exe)をコピーし、
同フォルダに、MCPatcher実行.bat という名前で、以下のバッチファイルを作成します。
コード: 全て選択
set APPDATA=%CD%\
mcpatcher-2.3.5_01.exe

このバッチファイルを実行すれば、M:/Minecraft1.2.5/ 用のMCPatcher HD Fixが起動します。
MCPatcher HD Fixの設定ファイルは、M:/Minecraft1.2.5/.minecraft/ に作られます。

同様に、
M:/Minecraft1.4.5/ に1.4.5用のMCPatcher HD Fix(mcpatcher-2.4.3_04.exe)をコピーし、
同フォルダに、MCPatcher実行.bat という名前で、以下のバッチファイルを作成します。
コード: 全て選択
set APPDATA=%CD%\
mcpatcher-2.4.3_04.exe


これで各フォルダごとに設定を使い分ける事ができます。
最後に編集したユーザー takanasayo [ 2012年12月08日(土) 08:55 ], 累計 5 回
アバター
takanasayo
ID:c4f2ee5c
ラピスラズリ収集家
 
記事: 954
登録日時: 2012年7月26日(木) 04:00
お住まい: 石の中にいる

  • (PostNo.65957)

Re: 【よくある質問】MCPatcherでMODが導入できない

投稿記事by takanasayo » 2012年12月02日(日) 23:56

MCPatcher HD Fixで導入できない質問が単発の方に頻繁に上がっていたので、目立たせるため&誘導用に立ててみました。
多くの項目がMCPatcher HD Fix関係なく、MOD導入時の注意になってますが、それはまあ^^

上記の全てを確認しても問題が解決しない場合、

・MCPatcher HD Fixのバージョン(ファイル名)
・導入しようとしているMinecraftのバージョン
・導入しようとしているMOD全ての名前とバージョン

を明記して、コチラのトピックに質問してみてください。

※注意
・MODの導入は一気に行わずに、一つずつ試してください。
アバター
takanasayo
ID:c4f2ee5c
ラピスラズリ収集家
 
記事: 954
登録日時: 2012年7月26日(木) 04:00
お住まい: 石の中にいる


Return to 質問:MOD/テクスチャ/その他ツール関係

x