【Windouws】【forge1.7.10】ジエンドに入ってからサーバーがクラッシュする

サーバー運用される方はこちらで情報交換されてはいかがでしょうか?
フォーラムルール
質問関連フォーラムで質問する時は、必ず次のトピックを一読/厳守お願い致します。
viewtopic.php?f=5&t=999
  • (PostNo.219598)

【Windouws】【forge1.7.10】ジエンドに入ってからサーバーがクラッシュする

投稿記事by achan » 2015年3月01日(日) 11:52

初めて、このフォーラムにトピックを立たせていただきます。
ガイドライン等は目を通しましたが、至らない点がある場合はご容赦ください。

さきほどまでMinecraftをプレイしておりましたが、ジエンドに突入した瞬間サーバーがクラッシュし、
それから何度起動、ログインを繰り返してもすぐにクラッシュする状態が続いています。
それまではまったく問題なく動作しておりましたので、突然のことで大変とまどっております。
クラッシュレポートは添付のとおりです。
お力をお借りできれば幸いです。

もし他に何か必要な情報等ありましたらお声がけください。

使用環境
Windows7 Ultimate 64bit
CPU 4.0GHz Intel Core i7
メモリ 32GB
Minecraft 1.7.10
MinecraftForge クライアント側 1.7.10-10.13.2.1291
サーバー側 1.7.10-10.13.2.1291
追加MOD
1.7.10_AM2-1.4.0.008
AccessChest+_1.7.10-v1.0.3
AnimationAPI-1.7.10-1.2.4
chocolateQuest-1.7.10-1.0
ShaderModcore-v2.3.28-mc1.7.10-f
Thaumcraft-1.7.10-4.2.3.4
CutAllSMP_v2.4.9
添付ファイル
crash-2015-03-01_11.36.37-server.zip
(1.63 KiB) ダウンロード数: 85 回
achan
ID:f97d7119
水から上がったとこ
 
記事: 5
登録日時: 2015年3月01日(日) 11:39

  • (PostNo.219623)

Re: 【Windouws】【forge1.7.10】ジエンドに入ってからサーバーがクラッシュする

投稿記事by ブリアレオス » 2015年3月01日(日) 14:31

achan さんが書きました:java.lang.NullPointerException: Error loading dungeon from missing folder: C:\Users\ユーザー名\Desktop\forge-1.7.10サーバー\config\Chocolate\snowCastles
at com.chocolate.chocolateQuest.builder.BuilderHelper.getRandomNBTMap(BuilderHelper.java:498)
at com.chocolate.chocolateQuest.builder.BuilderTemplate.generate(BuilderTemplate.java:54)
at com.chocolate.chocolateQuest.WorldGeneratorNew.generateBigDungeon(WorldGeneratorNew.java:150)
at com.chocolate.chocolateQuest.WorldGeneratorNew.generateSurface(WorldGeneratorNew.java:100)
at com.chocolate.chocolateQuest.WorldGeneratorNew.generate(WorldGeneratorNew.java:62)

Chocolate Questの不具合かと思われます(参照フォルダのパスが間違っている?)
暫定的な処置として、
C:\Users\ユーザー名\Desktop\forge-1.7.10サーバー\config\Chocolate\config\Chocolate\Buildingフォルダ内の全フォルダを
C:\Users\ユーザー名\Desktop\forge-1.7.10サーバー\config\Chocolate\config\Chocolateフォルダにコピーしてみて下さい。

本件とは関係ありませんが、非ASC文字(半角カタカナ等。今回で言えばforge-1.7.10サーバーの「サーバー」)がパスに含まれるとトラブルの原因になる場合があります。
可能であれば非ASC文字を含まないように変更する事を推奨します。
 ■■ 投稿する前に ■■
  フォーラムルール
  質問関連フォーラムで質問する時は、必ず次のトピックを一読/厳守お願い致します。

  【必読】質問の仕方について
  viewtopic.php?f=5&t=999
ブリアレオス
ID:9bfe9c7d
掘り廃人
 
記事: 2513
登録日時: 2013年5月29日(水) 17:48

  • (PostNo.219753)

Re: 【Windouws】【forge1.7.10】ジエンドに入ってからサーバーがクラッシュする

投稿記事by achan » 2015年3月01日(日) 22:13

トピ主です。

早速のご回答本当にありがとうございます。
なんとかサーバー自体は接続を維持できるようになりました。

が、今度は画面が真っ暗で、何も見えません。
所持品等の画面は開けるのですが、画面一面が真っ暗になってしまい、動きが取れなくなってしまいました。

これも何か原因があるのでしょうか・・・
achan
ID:f97d7119
水から上がったとこ
 
記事: 5
登録日時: 2015年3月01日(日) 11:39

  • (PostNo.219754)

Re: 【Windouws】【forge1.7.10】ジエンドに入ってからサーバーがクラッシュする

投稿記事by elise_blacklab » 2015年3月01日(日) 22:14

achan さんが書きました:が、今度は画面が真っ暗で、何も見えません。

その時F3で出るy座標はどうなっていますか?
メイドつくってたりします.http://6docvc.net/
アバター
elise_blacklab
ID:9266fbd7
掘り廃人
 
記事: 2513
登録日時: 2014年6月25日(水) 18:30

  • (PostNo.219770)

Re: 【Windouws】【forge1.7.10】ジエンドに入ってからサーバーがクラッシュする

投稿記事by achan » 2015年3月01日(日) 23:20

x:101 y:49 z:-1
となっています。
地図MODが入っているのですが、動けはしているようです。
が、画面は真っ暗で何も見えません・・・
achan
ID:f97d7119
水から上がったとこ
 
記事: 5
登録日時: 2015年3月01日(日) 11:39


Return to 質問:マルチサーバー運用

x