EclipseでのModdingでテクスチャが読み込まれない

Modding・サーバPlugin制作・ツール制作など、開発関連の質問があればこちらにお願い致します。
フォーラムルール
質問関連フォーラムで質問する時は、必ず次のトピックを一読/厳守お願い致します。
viewtopic.php?f=5&t=999
  • (PostNo.321375)

EclipseでのModdingでテクスチャが読み込まれない

投稿記事by WEsainT » 2018年10月27日(土) 22:41

Eclipseでマインクラフト1.11.2のMODを作成しています。
なぜかSoul Stealerというアイテムだけテクスチャが反映されません...
IDはsainvariousmod:soul_stealerです。
テクスチャの名前もsoul_stealer.pngで
Model読み込みファイルもsoul_stealer.jsonで
中身も間違えてないか確認したのですが反映されません。
jsonファイルの中身は

{
"parent": "item/generated",
"textures": {
"layer0": "sainvariousmod:items/soul_stealer"
}
}

です
(ModTools.java)にアイテムを登録しています。
miyabi@運営チーム[運営宛のメッセージ(PM)を作成] 投稿先違いのため、トピックを移動しました。
MOD開発の質問は『質問:開発・制作関連』に投稿して下さい。『質問:MOD/テクスチャ/その他ツール関係』はMODを使う側の質問場所です。
またモデレータ用タグは、許可無く勝手に削除しないようにして下さい。
最後に編集したユーザー WEsainT [ 2018年10月28日(日) 08:40 ], 累計 1 回
配布ページ作りました(まだDLできないし、サイトもテンプレやし)
https://distribution.client.jp/
まあ配布開始したらDLしてみてね~
WEsainT
ID:c90c76eb
木を殴ってる
 
記事: 18
登録日時: 2017年11月25日(土) 19:16

  • (PostNo.321387)

Re: EclipseでのModdingでテクスチャが読み込まれない

投稿記事by WEsainT » 2018年10月28日(日) 08:39

他のツールはテクスチャが読み込まれます
配布ページ作りました(まだDLできないし、サイトもテンプレやし)
https://distribution.client.jp/
まあ配布開始したらDLしてみてね~
WEsainT
ID:c90c76eb
木を殴ってる
 
記事: 18
登録日時: 2017年11月25日(土) 19:16

  • (PostNo.321416)

Re: EclipseでのModdingでテクスチャが読み込まれない

投稿記事by ペコリン » 2018年10月28日(日) 18:52

WEsainT さんが書きました:Eclipseでマインクラフト1.11.2のMODを作成しています。
なぜかSoul Stealerというアイテムだけテクスチャが反映されません...
IDはsainvariousmod:soul_stealerです。
テクスチャの名前もsoul_stealer.pngで
Model読み込みファイルもsoul_stealer.jsonで
中身も間違えてないか確認したのですが反映されません。
jsonファイルの中身は

{
"parent": "item/generated",
"textures": {
"layer0": "sainvariousmod:items/soul_stealer"
}
}

です
(ModTools.java)にアイテムを登録しています。
miyabi@運営チーム[運営宛のメッセージ(PM)を作成] 投稿先違いのため、トピックを移動しました。
MOD開発の質問は『質問:開発・制作関連』に投稿して下さい。『質問:MOD/テクスチャ/その他ツール関係』はMODを使う側の質問場所です。
またモデレータ用タグは、許可無く勝手に削除しないようにして下さい。


アイテムのテクスチャが反映されない、というのはMISSING_TEXTURE(黒と紫のアレ)が表示されているということでしょうか。
考えられる原因は複数ありますが、他に追加したアイテムが表示されているということなので、テクスチャやjsonのフォルダ構造は正しいと推測します。
ModelResourceLocationの第2引数に文字列を直接入れているならtypoしている可能性が考えられます。
アイテム.getRegistryName()で指定しているならアイテムの名前をtypoしているかもしれません。

起動時にリソースファイルが見つからないというエラーがコンソールに表示されているはずですので、エラーメッセージを確認してください。
村人をメイドさんにするMODを好き勝手に作ってますん
アバター
ペコリン
ID:b86e9fbd
石炭掘り
 
記事: 174
登録日時: 2016年5月01日(日) 20:56

  • (PostNo.321510)

Re: EclipseでのModdingでテクスチャが読み込まれない

投稿記事by WEsainT » 2018年11月03日(土) 09:13

[09:12:49] [Client thread/INFO] [sainvariousmod]: Register render for tin_ingot
[09:12:49] [Client thread/INFO] [sainvariousmod]: Register render for heart
[09:12:49] [Client thread/INFO] [sainvariousmod]: Registered render for tin_ore
[09:12:49] [Client thread/INFO] [sainvariousmod]: Register render for tin_pickaxe
[09:12:49] [Client thread/INFO] [sainvariousmod]: Register render for tin_axe
[09:12:49] [Client thread/INFO] [sainvariousmod]: Register render for tin_hoe
[09:12:49] [Client thread/INFO] [sainvariousmod]: Register render for tin_shovel
[09:12:49] [Client thread/INFO] [sainvariousmod]: Register render for tin_sword

この中にsoul_stealerはありませんでした。
配布ページ作りました(まだDLできないし、サイトもテンプレやし)
https://distribution.client.jp/
まあ配布開始したらDLしてみてね~
WEsainT
ID:5bfcdfb0
木を殴ってる
 
記事: 18
登録日時: 2017年11月25日(土) 19:16

  • (PostNo.321512)

Re: EclipseでのModdingでテクスチャが読み込まれない

投稿記事by WEsainT » 2018年11月03日(土) 09:15

public static void registerRenders() {

にSoulStealerを追加していませんでした。
返信ありがとうございます。
配布ページ作りました(まだDLできないし、サイトもテンプレやし)
https://distribution.client.jp/
まあ配布開始したらDLしてみてね~
WEsainT
ID:5bfcdfb0
木を殴ってる
 
記事: 18
登録日時: 2017年11月25日(土) 19:16


Return to 質問:開発・制作関連

x